[solved] UAD and Focusrite Liquid Mix plugins not working

Thought I’d start a new thread for this;

In Renoise 2.8.1 64bit, both the Focusrite Liquid Mix and UAD1 card plugins are not working properly.

Both exhibit a similar problem, you can only load 1 instance of the plugin. Attempts to load subsequent instances result in errors.
In the case of the UAD1 card, the following error is thrown “Sorry, one or more UAD Powered Plug-Ins have been disabled. The UAD-1 is already being used by another application”
and in the case of the Focusrite Liquid Mix, the following error is thrown “WARNING: No LiquidMix Hardware has been detected Please check that LiquidMix is connected to the computer and try again”.

In both cases, the first instance of the plugin works without a hitch. There is no problem at all in the 32bit version of Renoise.

Interestingly, using versions of the plugins bridged with JBridge does not help. The same errors happen there - so it’s not, as I first thought, a problem with the Renoise bridge.

Strange!

People have reported problems with UAD before. Have you checked the drivers? Using a specific version may help.

http://forum.renoise.com/index.php?/topic/29548-buggy-plug-heavy-cpu-spike-loading-first-uad-1-dsp-plugin/


http://forum.renoise.com/index.php?/topic/17809-buggy-installation-some-uad-1-vst-plugins-crashed-during-scan/

HotelSinus is a UAD1 user, he might be able to help out or perhaps others as well.

No problems with my UAD2 in Renoise and native 64 bit plug-ins.

This is a problem not related to Renoise, but to UAD. Since the UAD-1 only has 32 bit plugins, they need to be bridged on 64 bit sequencers. Unfortunately the plugins seem to be incompatible with VST bridges, so the only option is to stick with 32 bit sequencers or upgrade to a UAD-2 (you will lose the Nigel plugin though). The support for UAD-1 was discontinued when they released the 64 bit plugins for version 2.

According to Focusrite, the Liquidmix also has problems with x64 sequencers.

Not true for me at all. Both my UAD1 and Liquid Mix are absolutely fine being bridged in all other DAWs I’ve tried. Used them for years that way. It’s only Renoise64 that has these problems so far.

Again, the first instance of the UAD1 plugin loads with no problems… it’s only when you try to instantiate another that the error is thrown. This is also the case with the liquid mix.

I quote Vv here:

"Perhaps there might be some kind of limit in how many instances are allowed to be opened seperately. When bridged, each instance runs fairly stand-alone. Inside Renoise 32-bit, they are all part of the same host, i guess that might be the problem.
So perhaps the bridge server should perhaps allow a single root thread with plugin branches of the same plugin instead of branching out multiple root sessions
. "

It is odd however that the UAD plugins behave like this, while tons of others (commercial and free) work flawless when bridged. Even Sonar and Cubase users report this behaviour.
However, it seems that JBridge has a work-around for the problem by enabling the “Run in existing auxhost” option. I do not know if this will work with Renoise though.

I tried the “Run in existing auxhost” as you suggested and bingo, it works! Thanks for the tip MSXUser - it’s much appreciated.

Now I suppose the question is what is this doing in JBridge, and could this be applied as an option in the Renoise native bridging functionality? Devs, What say you?

I’ve just been given a liquidmix…looks like a nightmare to get working on 64 bit systems! Will see how I get on.