[solved] Undo in Sample Editor does not work?

Out of nowhere, my Renoise has been acting up. Whenever I trim a sample, it won’t undo properly. The bottom of the screen says “Trim sample undone” but looking at the sample editor, I can tell that the action wasn’t done. After a few tries, it will just get to the point where it will unload the sample.

Any clue on how to fix this? I tried reinstalling.

I’m currently using x64. Is this the culprit?

Update: Yea I can’t undo trim samples at all. Not with ctrl-z or the edit/undo.

Did you enable “undo” checkbox in the bottom left corner of the sample editor?

Oh my god! I feel so stupid… THANKS

Made the same mistake once… :slight_smile: Maybe it could be enabled by default…?

Maybe it could be enabled by default…?

On a fresh install with a clean config, it should be enabled by default.

what is the point of disabling undo?!

(to save memory maybe?)

I sometimes use it when editing very large samples. Saves a bit of time.