[solved] very weird audio problems...

Hello. I’m trying out renoise and i love it. However i have a weird problem. Audio level from an instrument will sometimes drop when audio starts from another one.

Here is an example with only two sounds : http://www.filehosting.org/file/details/489937/test.wav

(recorded with a free vst recorder since demo version won’t render)

The weirdest thing is that the db meters do not see any changes

Normal levels will resume after some time, or upon restarting transport.

This problem happens sometimes, sometimes not.

It doesn’t make sense at all

I didn’t find anyone with the same complaints, so i’m assuming this is just my computer.

Any clue of why/how to change it?

This is windows 8.1 running renoise 3.0.1 demo (uninstalled and redownloaded and reinstalled just to be sure)

wtf seriously

Are you using a single VSTi in multiple tracks? Can you upload the .xrns?

Can you upload the .xrns?

Yeah, please upload the .XRNS song so we can examine it more closely.

And please use a file host that doesn’t require the user to enter their email just to download something. Last thing people need is more spam in their inbox.

sorry about that. i use an email that is already rotting with spam.

here is the xrns but there is nothing in it really just two samples playing. i made the simplest file that exhibit this behaviour but i reckon it should work just fine in your computer. im really confused as this is completely beyond logic. i mean it has to happen inside renoise but this is the same renoise everyone uses…

apart from that great piece of software by the way. love the ultra fast sequencing with computer keyboard and also the scripting api seems well thought out (contrary to m4l which is really unpractical). and the sampler of course

I think you forgot to link the .xrns.

BTW just for in the future this is a really good place to upload audio clips you want to share for stuff like this:



if you use Instruments there is currently the following limitation in Renoise: If you use dsp devices inside the instrument, you have to you the instrument only on one track. If you use it on more than one, strange note missing will appear. This is since Renoise would need to provide more detailed routing from inside to outside an instrument (which is already heavily requested here) or had to automatically double the whole instrument instance with all fx in precalculation (which would be quickly a cpu and memory mess I guess).

A similiar (but this time quite usual?) limitation appears if you use an vst. Maybe I do not describe this 100 % correctly: If you use an vst, you cannot play it in polyphonic way over multiple tracks with different dsp each. This is quite logical since the vst generates the polyphony already inside itself and then puts out the sum to Renoise, so Renoise cannot split the sum magically again. I think thats why you have to put an instrument directly to an track in Cubase. If you put it to another track, it will open another instance. You have to do this manually in Renoise (just double the instrument entry, if you want to play it on multiple tracks).

the xrns 5675 test.xrns + audio in clyp.it (https://clyp.it/pih12uyz)

thank you jurek but this is not the source of my problem.

I don’t really hear or see a problem. Maybe you’re hearing the tail of the snare masking the piano note? The snare is way louder than the piano to the point where you can barely hear the piano, it doesn’t take much for something so quiet to be masked. You can even visually see that the waveform of the piano sample at no point in time is even close to the loudness of the snare until the tail fades completely.

Turn the snare down about 21 db and it should sound fine to you.

edit: Also set the NNA of the piano sample to continue, or to note-off and create an envelope that fades it out quicker, and it’ll sound more natural and less like a sample being cut off halfway through every note.

the problem is even when the snare is completely over the piano sample doesnt regain its level

Maybe there is some “compression” going on in your analog output? E.g. too much volume… I cannot hear a problem, too. Also not in your wav example.

even when the snare is completely over [,] the piano sample doesnt regain its level

I’ve checked out your .xrns, and I also used a throwaway email address to download the original test.wav you uploaded earlier.

I cannot hear or observe any problems here. The piano sample retains the same volume level before and after the snare hit. It sounds the same in your test.wav, when playing the .xrns here myself, and also after rendering my own wav.

If we look more closely at your original test.wav in the sample editor, and zoom in closely to better view the amplitude of the piano sample (ignoring the massive zoomed in spike from the loud snare for the moment), then we can see that it maintains the same level before and after. I’ve highlighted this by painting a simple horizontal line over the image, so you can clearly see that the piano is always peaking at the same level.

5676 renoise-weird-audio-problem.png

When comparing such a quiet piano sample against such a loud snare hit, I think there’s a chance you could be perceiving an audio difference that isn’t really there. Especially if you are playing this back on some loud speakers or headphones, your ears will get a temporary “shock” from that loud snare hit, and may naturally take a short moment to readjust.

Alternatively, there’s a chance it could be your Windows audio card settings. Do you use a Realtek onboard sound chipset or something similar? Does your audio card have any kind of additional processing, like reverb, EQ, stereo enhancement, active compression, loudness compensation, etc? It’s possible that you have some “enhancement” enabled which is interfering with your final audio output.

One thing’s for sure: your test song does not demonstrate the problems you’re describing, so the problem is coming from somewhere else.

I checked my test.wav in an audio editor (renoise^^) and indeed in the file all piano hits are of equal loudness. So this is not renoise. Should have done this before posting sorry.

But this is not a perception thing. Experiment : i open the wav in vlc, hit play, wait for the tail of the snare to fade, then quickly hit spacebar twice to stop/restart playing. And instantly the piano samples jump in volume. So there must be something wrong with my audio settings as you say, but what exactly? This is a relatively new computer but in 6 month i never noticed anything like that.

I’ll try to find out when i have the time (right now i’m a bit busy) but if i can’t i’ll seek help somewhere else since it’s definitively not a renoise issue and you can’t do much more than the previous post. Thank you for your help, and i’ll come back and tell you when it’s fixed

open the wav in vlc (…)

I know that VLC has both a Dynamic Range Compressor and a Volume Normalizer available in its audio filters. Is it possible that you’ve accidentally enabled one of these at some point in time? If you only experience this problem when playing the .wav in VLC player, then one of these might be the culprit.

no filters are activated in vlc, plus it’s the same wether playing the wav in windows media player or renoise.
for window media player hitting twice pause play doesnt readjust volume though

in renoise volume readjusts after restarting the wav by sending another note on. (i cut the silent part in the begining to make it clear)

what i dont understand is : on one hand the problem seems to be at the very end of audio path since i tried with different playback applications

but one the other hand the difference of behaviour between vlc and window media player

i mean if the problem is with the soundcard/the driver, how can it know that i pushed twice spacebar in vlc and do something accordingly

edit: ok i have news! it’s the driver! i tested with another daw where i can switch between native driver and asio (impossible in demo renoise) and asio works fine!

that also explains why i didn’t notice it before!

so i don’t fully get the why but it doesnt matter because when i buy renoise i’ll use asio