[solved] VST Song Loading "Compatibility" Problems


I`m wondering about something:

Once I made a song with Renoise 1.9.1 on my old PC. (WIN XP SP1)
Now I wanted to continue working on the song on my new PC (WIN XP SP2) with Renoise 2.0 and it tells me that most (not renoise native) Vsts and Instruments (Vsts) could not be found!

But they are THERE! Its even the same directory path, and all the same versions.

The odd thing is, as a test, I installed Renoise 2.0 on my old PC and there the Song loads properly. o_O

I saved it on the old PC with Renoise 2.0, hoping it might then work on my new PC with 2.0 but it didn`t.
And I installed Renoise 1.9.1 on my new PC but with that it still reports the missing Vsts. :o(

There is one difference which might have something to do with that problem: Old renoise displays the Vst name only, new shows the authors name additionally. (e.g. old: CLASSIC FLANGER new: KJAERHUS CLASSIC FLANGER). But thats not it, is it? I mean, on my old PC there occur no problems loading the tune with REnoise 2.0. So it must have something to do with my new PC…?

Maybe that my WINXP on the new PC is SP2 and on the old its SP1 ?
Could that be?

Did anyone experience similar problems?
And found a solution?

Is that problem known to you in any case, dear Renoise programmers?

Or do I have to load in the missing plug ins manually and edit the values again? :o(


This happens only for some plugins, not all VST pugins?
You have to make sure that you are using the same plugin versions that you used before. Renoise will match the filenames of the DLLs to identify the plugins.
Have you probably renamed them on your old setup? Are you sure that you’ve installed the correct/same bundles again?

Well, some work, some don´t. I just copied the whole VST folder from my old PC to the new one. Same path, same names, same versions. And all the Vsts (Effects as well as Instrument VSTs) now reported missing by the song are actually working fine, when I use them in a new project.

I know that some more complex VSTs won`t work, if not installed from their install.exe, but the reported-as-missing VSTs are partly simple dlls, which have to be just copied into the VST folder.

And to repeat it, loaded into new projects the VSTs work.

The “Show Missing Plugins” dialog in “Renoise” -> “View” should give you the (file)names Renoise is looking for. On Windows, the names there are simply the filenames without the .dll suffix.

Are you sure that those files are there and are present in Renoises FX/Instrument lists?

Which VST are for example missing, not found?

Yes, Im sure they are there.
I can just simply load them in, same slot I`ve been using them, and they work. But off course all settings are set to default, without the changes I made particularly for the song.
Off course I can have both PCs running and enter the old values from the old PC manually, but thats not the point.^^

Things I observed:
thats how that vst is displayed in my Windows Explorer, with the visible affix.

Goddamit, wtf? On my old PC the file is showed/named as ----> Classic Compressor.dll
Small letters, and without “_”

I renamed the file like that, and now it works. o_O

I tried that in reverse, renaming a dll, like its named on my old PC, to look if a song completely made on my new PC can load it…and it loads…WTF?^^

How the hell did that happen? I mean I simply burned my VST folder on a CD and put it onto the new PC.
All filenames are in capital letters and gaps are filled with the “_”.

Did the burning program that to the filenames, or is it a settings/display issue on my Windows? Okay, you`re no oracle, but might it be something like that?^^

So, the solution is, to rename the Dlls, like they are named on my old PC, but I don`t get the reason, why it wont load the old song on the new PC proplery, but in reverse there are no such problems, loading a new song, using the dlls with the old filenames. o_O

Did I discover a bug, or is it a fact, that it have to be like that?

Yeps, the burning program did that if you picked a specific ISO standard to write your file structure.
It might also have capped files containing more than 28 characters (old Macintosh limitation)
Better delve into your help manual of your burning program or just google for ISO 9660 standard.

At least this is no bug from Renoise but a cause that came from an unexpected corner.
You may get problems in other applications as well because of this, so better try to reburn a new cd if you can.

A filename being capped should make no difference, but an underscore character that replaces a space is not the same file anylonger.

…der Teufel steckt im Detail…^^
dunno how to translate that properly…the devil dwells in the detail…or so…^^

anyway, thanks for the replies and concern to my problem :)

I`ll burn a new CD then…^^