Spectrum View L+R Mix Option Can Cause Crackles

When I switch to the master spectrum view , highest settings and set it to L+R summing , I get a lot of crackles …buffer underruns , even when the cpu is load is verry low …
How can the master spectrum view affect m soundcard latency …if so shouldn’t this happen when the cpu load is high …and not low
In the previous betas ( befor beta 5) was the spectrum always calculated in mono ?

no one …c’mon c’mon …bufferunderruns (crackles and clicks ) when low cpu load

maybe it helps if you post your system specs, os, soundcard(settings) etc?

more info please ? especially we nee to know your soundcard settings (buffersize, samplerate etc.) and which settings you have in the spectrum…

When the set latency is small, let’s say 32 samples, then Renoise calcs everything in blocks of 32 samples in the audio engine.
To do an FFT with a block size of let’s say 16384 it can only calc the FFT every 16384/32 times, but then for the entire FFT block size in one go - in one audio buffer.

This results in an relatively low !average CPU! usage, but as soon as the FFT has to be calced in a high !CPU peak!. This may lead to buffer underruns, crackles.

With the new “L+R” option there are now also 2 FFTs calced at once per buffer. So this cranks up the CPU usage even more (effectively to 32768 samples an FFT is performed on).

Avoiding this is possible, but far from trivial. I’m not sure if we can do this during the beta, if it’s worth it.

I think it may make more sense if we do try to lower the block rates, overlapping and also get rid of the dual L+R mode. It’s nice to have them, but it’s also a bit frustrating that they do need so much CPU. Especially for those who do not have a fast computer or want to work with extremely low latencies.

Alternatively somehow try to make clear THAT they can overload your CPU, can cause crackles at some point and you have to apply the settings wisely that do work for your setup. I’ve no clue how to do so if we don’t want to pester users with warning message boxes.

L+R is an optional mode. Nothing is forcing anybody from using it if their computer can’t handle with it. The advantages greatly outweigh any negative IMO, you just need to make sure you set your settings suitably.

Although, on that note, would an idea of slightly shifting left and right calculations help at all? Say one or two buffer sizes apart? Then the spikes for each will be lower and slightly different in time. It might be arguably slightly less accurate (but whether noticeably at all is very arguable) but if it does help with CPU loading it may be worth considering.

Maybe change the CPU meter in Renoise to display peak value over a period, so it does represent these spikes to users and they don’t think it’s not being overloaded?


we can decrease the overlap average of frames but then other people will complain about the framerate or the peak fall response time

maybe show in the graph window % CPU used as in plugin tab.

Well I am using a old amd athlon 64 3000+ …
Only happens when set the spec(trum mixdown to l+r …but , the clicks ( buffer undrruns ) sometimes go away when I reset the audio engine ( double cliçck stop )
I just thought it was strange that I had clicks and underrruns even when the cpu load in renoise is low (about 20 percent ) howeve ,window taskmanager shows the opposite …and indicates a high cpu load .

I’ll just stick to mono spectrum .

Just make is public knowledge that it’s a “High CPU” option. Much like oversampling is an optional risk.

( ) Don’t show this message again for this session.
(x) Never show this message again.