Suddenly Can't Use Numpad Anymore

…help?
I don’t get it. Yesterday I was just switching between octaves with numpad+div and numpad+mult and I was switching between instruments with numpad+plus and numpad+minus. Today these shortcuts simply don’t work anymore. I can still assign them in the preferences but they just don’t do no more when I’m using them. Seems like some other part of Renoise has got focus. But I don’t know how I got into this. Even if I explicitly change the focus to the instruments with alt+click, then I still can’t use my shortcuts. This is a bit embarrassing to me because it has to be some obvious mistake of my own but I can’t figure out what and how. Please someone help me.

Thanks in advance.

hmm maybe posting your config.xm and keybindings.xml may help us finding the problem

Sorry, didn’t think about that. I attached the files to this post now.

Thanks.

edit: removed somehow doubled text

a little off-topic but:
Internet Explorer I presume?
Use Firefox instead…

You didn;'t happen to activate stickey keys or something similar? (some kind of keyboard driver software that programs your keys or similar)

Hi vV,
nono, I was on Linux and I do use Firefox. But how could it have an influence on the shortcuts at all?
edit: unbelivably concentrated I am :)

Hmm…Have no clue of what I could have done that way. I know that setting up the keyboard was a bit tricky for me under Ubuntu. But then there is this “override” feature in Renoise. Having it turned on, shouldn’t it be able to scan the keys independent from any other layers?

Linux is a very different story, if you forget to mention that in the first place… Windows is assumed at first :P
If things or behavior changes, regardless of the platform i always sum up a list of questions in my head:

-Did i added any hardware lately (and had to change drivers)?
-What kind of system-updates have been applied lately?
-What Software did i installed lately?

Anything that got added, changed or updated in the software environment can have its effects, specially coming out or corners where you didn’t see it coming from.

I had to revert a Windows system update because some component of the update caused my Windows to terminate into a BSOD as soon as i attempted to make a VPN connection to my office.

An acquintance of mine has Linux running (Ubuntu) that i installed. That ran fine until they decided to allow an upgrade from Ubuntu 7.10 to newest Ubuntu desktop 8.x
I turned off automatic updates for them because it took me a whole night to fix a lot of broken symlinks and half-wiped software configurations that were specially installed for their system (upgrade scripts don’t incorporate custom system modifications)

Really appreciate your help. My OS is mentioned in my footnote since a couple of months but I understand that it’s not obvious to see such tiny preset-texts sometimes.

Yes, that’s one ugly thing that could remain. I’ll look it up.

[SOLVED]
After fiddling around a bit more with the numpad, I noticed that it was acting as a mouse (up, down, left, right). So I googled and found this thread to be a good hint. The exact way for my solution goes like this:

System -> Preferences -> Keyboard -> Mouse buttons -> Uncheck “Control mouse cursor with keyboard”

Sad but true: I had never ever changed this setting on my own.

Thanks for your time everyone.