Terratec ASIO & 96khz SampleRate Playback

Hi there, I wanted to try out Renoise it’s capabilities of playing back at higher sampling frequencies to see what that would be like.

I tried 192Khz, which sped up playback of the entire track by a lot. But that kind of makes sense because this website tells me Renoise supports exporting up to 96Khz and 32bit, which would make me think that would be the maximum playback specs as well.

Anyway, it seems like playback rates are fixed at 44.1Khz for some reason within Renoise. Playing at 96Khz causes my track to be sped up significantly. Same goes for 48Khz, albeit less than 96Khz (which makes sense).

My card was locked at the sampling rates of 48Khz & 96Khz while testing. No application could change the bitrates. Renoise took over the set rates of 48Khz & 96Khz correctly but proper playback failed.

Personally, I couldn’t be bothered to use playback rates above 44.1, but I was just interested in how this would work…

I hope this explanation makes sense.


If I unlock the sampling frequency on my soundcard Renoise does play back correctly up to 192Khz. So it seems like Renoise doesn’t take over the set sampling frequency properly… It says 48000 or 96000 in the preferences but doesn’t play at those rates when my soundcard’s sampling frequency is locked (which causes the audio to be sped+pitched up). Would the problem be Renoise, or the drivers? (the drivers seem proper though, never had any stability issues)

I use an Echo audiofire12.

this problem also arises with some Terratec cards. I had it with my old EWX 2496, now I don’t have it anymore so I can’t confirm it’s still there.

by the way, why do you use the rate locking in the end?

Because that prohibits other applications from messing with my sampling frequency settings. :)

I always use locked sampling frequency, but normally it’s locked to 44100, which is standard for almost everything. So i didn’t notice this problem before with Renoise because I guess that functions on 44100Hz normally as well. It’s no biggie though, and certainly not a problem that has much relevance, as it can be solved quite easily.

It’s the other way around. Sorry if my first explanation didn’t make that clear.

When I unlock the playback frequency, renoise let’s me choose the sampling rate (with the dropdown menu) and everything works fine.

When I lock the soundcard on, say 48khz, Renoise says it uses 48khz (which is the only option available, which is correct, because the soundcard is locked) in the preferences dialog. However, Renoise doesn’t play back at 48khz as it should, causing the song to be played back at a higher speed.

There where no other applications running at the same time.

Interesting. It seems that windows itself is actually the cause of the playback speed being incorrect. The above settings solved the problem with renoise playback speed at fixed sampling frequencies. Fucking microsoft.

Thanks for the insight Bantai :)
I’d say, put [windows-bug] in the header :D

If you lock the samplerate in the driver configuration, you cannot influence it in applications.
Neither in Renoise, except indeed that the change causes the output to be a multiplication or a division of the reference locked samplerate.