The global command ZL causes renoise IDE to lag

Using the global ZL-command (which change value) on every row causes renoise IDE to graphically lag like crazy. The pattern-view, the main volume bar in the top lag like crazy… Mouse cursor floats around like normal tho.

A great example is to open up WAVE’s (Jeroen Tel) - 911 and during the funk parts renoise goes very choppy and becomes very unresponsive until you stop the song. The actual playback barely cost any cpu.
The same phenomenom does not happen in milkytracker when playing the same song.

Try this file:

And put pattern [2] on loop.

Guess my computer is too crappy… i5 just doesn’t cut the deal. But still the same problem does not occur in milkytracker! playback in renoise is much more cpu demanding? Is there any way to make the ZL/ZT commands be less intense on the gui update?
This is more of a feature request than an actual bug TBH.

I can’t confirm the problem on my Windows 7 64 bit machine with an old NVidia GeForce 8400 GS. Have you tried tweaking Edit => Preferences => GUI => Globals options?