Toggle Recording State With A Midi Controller

edit- I meant “edit mode”

I’ve been playing around with the new midi mapping and my akai mpd24, and it works pretty great. I noticed one small thing, though: when I press the record button on the mpd24 Renoise enters edit mode, but when I press it again, nothing happens. I would expect the record button to toggle between edit mode on and off. Does it work this way on purpose? And if not, can you change the behaviour of the record button?


Click ctrl+m to enter the midi-mapping screen, check the global mappings.

Click ‘transport’ than go to ‘edit’, I think you need to map edit mode to ‘set’ instead of toggle or vice versa?

Thanks for the reply, but that doesn’t work. The problem here is that I can’t map the transport buttons. The MIDI learn function ignores them. Of course, I can map a midi note to edit mode [toggle], but why should I have to do that when there is a dedicated record button?

Nevermind, it turns out that I can change the function of the transport buttons from MMC to midi control messages, and then map them.

This is what we do on MMC commands:

Stop: Stop
Pause: Stop
Play: Play (at current patterns start)
Continue: Play (continue at old position)
FastForward: move forward by 4 beats
Rewind: rewind by 4 beats
PunchIn: enable EditMode
PunchOut: disable EditMode
RecordPause: Toggle EditMode

so it looks like your controller has send a PunchIn?

I can’t find anything about it in the manual, it just says that it sends mmc data, but you’re probably right. Anyway, it’s not really important, since there is a simple workaround.


hey !

what`s a punchin ? :)

i bought an alesis qx49 yesterday and have the same problem, the record button doesnt set, it toogles. in midi mappings the key is mapped for set. i only played around with it last night, didnt really go through the documentation or something but i figured i`ll simply ask here, maybe this is known and easily avoidable … somehow ;)

i still didnt figure out how to fix that. "prefer setting instead of toggling" doesnt work, am i doing wrong something else ? the manual of my qx49 is 2 pages long and doesn`t tell me anything about that setting :mellow:

The button probably sends two (or more) different values on each press.
If you open up the duplex tool-menu, the bottom option says “Dump midi to console”. Check that one, you also need to have the Scripting and terminal enabled for that option to work (a link to the documentation is supplied in a dialog how to achieve that). If you have done all that, then pick any kind of mixer preset and any kind of device that shows in the menu, then click on the “settings” button, a dialog pops up and in there you select your own QX49 device (or de midi device your QX49 is attached to it) as midi input device.
Press the device its buttons and see what values appear in the Scripting terminal frame.
You get at least some insight of what messages your device is broadcasting.

hey, thank you very much!

i stumbled across a video ( while looking into another problem with the keyboard (the zone function on the display keeps flashing wich is kinda irritating …) and it mentions the transport button problem. i guess it`s just that, it sends two signals.

i mapped the drum pads for the transport functions and this way it works.

not perfect but it will do. in case anybody is looking into buying a qx49 keep in mind those two things are … not optimal ;)

edit: gaah actually it doesn`t work by assigning the drumpads …

edit2: i give up ^^ in case anyone wants to get a qx49 keep in mind that the keyboard itself is great but the transport and drumpads suck :)