Touchosc & Renoise


I just started using TouchOSC on an galaxy tablet and have been trying to get it to run with Renoise on OSX.

The problem i’m having is there aren’t any hosts appearing in Touch OSC to connect to

  1. The touchOSC bridge works just fine, so it probably isn’t the network
  2. Started the OSC server in renoise, and made sure the port numbers and protocol are correct
  3. Configuration options in Touch OSC are next to none… so nothing to do there

Anybody any ideas on how to do this? obviously I’ve searched the forums, but without luck

The OSC protocol doesn’t work like that. You simply send your numbers “into the wild”, and hope someone on the other end picks it up (hence the port/prefix system).

The TouchOSC bridge convert your OSC messages into MIDI messages, so you are no longer dealing with an OSC device then, and doesn’t need to use the OSC server. You should be able to select the TouchOSC bridge as a MIDI input in Renoise, but this doesn’t work?

You have not written anything about what you want to achieve, though. Want to code your own actions? See the GlobalOSCActions.lua document…
Want to run plug-and-playable/customizable applications, no coding involved? See the Duplex tool - it even comes with a TouchOSC layout.

True, i haven’t. Lets start from the beginning:

I installed touchOSC on the android galaxy tab. Then did some reading on how to set-up in Renoise. The first step was to set the right portnumbers and ip-addresses on both devices and start the server in Renoise with the corresponding portnumbers. The macbook should pop-up in TouchOSC on the tab according to their manual, but this fails… The goal is to use TouchOSC and Duplex to control Renoise.

About the TouchOSC bridge: I installed this in order to test if the two devices can even see each other (which works fine).

How do I have to do the set-up?

Ah, with Duplex setup is quite simple: you just have to enter the same IP addresses and port names.
The internal OSC server in Renoise is not used for this purpose (although Duplex is now using it for triggering notes, so you might want to leave it on).

For example: if your device states that it’s local IP address is, this is the number you enter as “address” in the Duplex options. The outgoing port on your device is the incoming port in Duplex, and vice versa. The “host” address in TouchOSC should auto-detect whichever address your computer has.

I remember someone had a problem with the IP addresses, and used the host-name instead, so if you’re running into trouble this might be worth trying out (but then you said that you got communication going with the bridge, so I am guessing your setup doesn’t need this)

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.