Ubuntu 64bit + Novation X-station + Alsa + Renoise

Hi, I’m trying to make Renoise 1.9.1 or 2 work with my X-Station as an audio card on Ubuntu 8.10 [amd64]. I have tried Jack first which didn’t work because of the compatibility issues already described somewhere here. So now I am trying with ALSA. It works fine with my laptop’s built in audio card but when I switch it to use X-Station’s interface it looks like it’s playing (the graphs are moving etc…) but there is no sound. I have checked all the mixer settings and nothing is muted.
Everything seems to be just fine and I think X-Station is installed correctly because I can play mp3s with Exaile. Any ideas?

The first problem is that Renoise is compiled in 32-bit, so you must either use 32-bit Jack or reinstall your whole Ubuntu in 32-bit.

Insert my vote for 64-bit Renoise on Linux here.

That having been said, I run on 64-bit Linux but don’t use Jack. I cross-compiled the LADSPA plugins in 32-bit and got a bunch of linux-native VSTs to work, so I have a good enough setup when I’m home. I have no issues getting the sound to play. Double check your Preferences to make sure Renoise got ALSA: if I so much as leave a web browser running flash open when I launch Renoise, it will fail to grab ALSA sound. :angry:

On the road, the laptop runs Windows XP :P

Best wishes and good luck

I know there are problems with 64bit distros but knowing that why would there be sound in Renoise with built in card and not with external one?
By the way - do you know if there is a big performance difference between 32 and 64 bit distros?

Does the device show on your Renoise preferences? What sort of error message do you get when you try to choose it?

You may have an issue similar to mine (that other sound-using programs must be closed so Renoise can take the device away full-time). ALSA has a psuedodevice called “dmix” that most audio programs will use, dmix can take input from many sound programs at once and if two try to use it at the same time, it will mix the two audio sounds together and play both sounds invisibly to the user.

I can’t get Renoise to use a dmix device, and this is probably by design: dmix introduces audio latency.

Yeah the device shows up and there is no error message at all. The graphs are moving when I press play and it behaves just like the volume was mute somewhere but I’ve check everywhere I could think of and everything looks ok.
I don’t know perhaps it’s some setting somewhere… I have installed 32 distro and it was still mute when using ALSA. Then I tried using Jack and it worked perfectly (didn’t crash like in 64bit distro) so I’m not that desperate to solve the ALSA mystery anymore. I realise XStation may not be the most popular audio interface in the world so I wouldn’t be surprised if it’s just some drivers issue…
Thanks for your suggestions and help.


Please HELP Me…
I Lost my driver CD for X-station USB…

Can anyone post in the Image File for the USB Driver CD???

It’s in gr8 need. please HELP!!!

Thanks in Advance