Volume Column, Effect Column, Shortcuts

When I’m in the notes column I can copy/paste with relative ease. I can have alternate notes and patterns and copy paste them down my whole song if I so wish.

When I move to the volume column I can’t isolate the volumn “column”. Say I want to repeat 80/60/40/20 indefinitely downwards. I have to manually type it. If I copy paste the four lines all the notes get taken with the volume command (and I only want the volume data taken). It’s like in Excel if I copy down a column I don’t want to take all the row data along with the column. I’m probably doing it wrong starting in the cell I want and holding shift plus the down arrow.

How can I copy strictly just the column data and not bring along the notes?

Better control over selections is coming in 3.1.

Until then, you can use the Advanced Edit panel found to the right of the pattern editor.

Expand the Content Mask section, then right click the Volume checkbox to quickly solo it and un-check all others. When configured this way, any copy/paste actions you perform in the pattern editor will only affect the volume column. Reset the content mask back to normal when you’re done.

PS. When you have something copied from the pattern editor, you can use the Paste Continuously function (Ctrl+P by default) to quickly fill the rest of the pattern.