VSTi in Renoise 1.2

Hi all! (-:

It’s my first post here, so let’s start with the obvious stuff: Renoise ROCKS! I’ve never seen such a cool music software. I liked Impulse Tracker (even registered it long ago), but Renoise is the next step in tracking.

What makes me love renoise is the ability to use VST instruments, some of which are really great (Rainbow 2 and Triangle 2 are my favorite). After having heard what those VSTis are capable of, I almost promised that I would never use a sample again (okay, maybe a drum loop here and there).

But, alas, I have a problem here.

Renoise 1.11 worked just the way I liked: I could tweak an instrument (or create it from scratch) in Rainbow 2, then its settings would be saved together with the song and recalled after reloading it, sounding exactly the same between sessions. I was very happy with it, but Renoise 1.11 had serious stability problems on my WinXP laptop: it would crash on startup most of the time with an “unhandled exception in audio”.

Renoise 1.2 looks much more stable (never crashed up to now), but -ouch!- it doesn’t save VSTi settings anymore! I just get the default sounds, losing my tweaks. So I tried to use an automation track (really cool idea, by the way) but, as I feared, only the parameters shown in the automation box are saved, the others are reset to their defaults. This might be okay for some little synths (like the JX220), but the Rainbow 2 has LOTS of parameters, and I wish I could be able to save them all, like before.

Hence my little suggestion for the next version of Renoise: would it be possible to save all the VSTi parameters together with the automation track, even if they are not shown there?

By the way, I also noticed that the CPU usage meter is totally messed up in 1.2. It looks more precise when I use Renoise as “Administrator” (still goes far beyond 150% even when Renoise works and responds just fine), but when I use it as an unprivileged user, it shows 11000% and over!

Well, that’s all for the complaints… I know they are frustrating for a developer, but hey – without these little bugs, Renoise would be perfect to my eyes (and ears). :wink: So thank you for having read so far, see you next time, and happy tracking meanwhile. (-:

has anyone else problems with restoring vsti settings ? Maybe this is only a problem with Rainbow II ?

about the cpumeter : this happens only on some Sony laptops as they dont support an assebly instruction that I use for the cpumeter. I will look for an alternative to fix this problem.

I’ve made a few tries, and found out that

  • Triangle 2 works correctly
  • Rainbow 2 and ZR3 lose their settings
  • JX220 doesn’t work anymore (the oscilloscope goes up off scale and, well, doesn’t oscillate at all)

My laptop is a Toshiba Satellite Pro 4300, Celeron/600 with 128 MB of RAM, S3 Savage IX video card, Yamaha DS/XG sound card. And the CPU-meter worked fine on 1.11. (-:

This is such a shame…

All of the tracks I have done on renoise have one compatibility problem or another with VST’s and VSTi’s…

I wouldnt mind so much but there are two tunes that I have had interest from a couple of labels and it’s going to take ages to replace the VST that dont work and re-make the VSTi synth sounds for re-render after doing the track polishing required… :(

Install a renoise 1.11 on your HDD too and finish the songs there. I have a song using pro-53 vsti and its not playing correctly in renoise 1.2. I just kept renoise 1.11 and finished it there. You miss the new features, ofcourse, but atelast you can continue to work.

Am I now annoyed that I never kept V1.11 :(

wiz :
Zed and me tested your problem again :
Rainbow 2 and ZR3 dont lose their settings. All parameters are properly restored after loading. Maybe you used an older version of Renoise ? If not, what exactly is not restored then ?

Well, I haven’t got a Renoise 1.2 under my fingers right now, but the problem is simply that with Rainbow 2 I can choose a preset (which IS saved with the song), but if I tweak it, the tweaks are lost when I reload the song. This happens when I load a song made with Renoise 1.11 (Rainbow 2 recalls the right preset, but no tweaks), and also when I make a new song from scratch with 1.2.

I will try again later and see if I’m doing something wrong, but the song I’ve made in Renoise 1.11 does sound different in 1.2.

let me please summarize your problem again :
vsti settings of some vsti’s in 1.11 songs are only lost if you load it into renoise 1.2, but they are properly restored when loading a 1.11 song in renoise 1.11 and loading a 1.2 song into renoise 1.2 ?
please correct me if this is wrong.

Almost correct, except that Renoise 1.2 doesn’t seem to load them at all.

I mean, here’s my typical session with Renoise 1.11

  • Run Renoise (hoping it won’t crash on startup, which it does most of the times I run it)
  • Assign an instance of Rainbow 2 to an instrument
  • Select a preset
  • Tweak it until it sounds the way I like
  • Compose the song
  • Save the song
  • Load the song
  • Everything is ok.

With Renoise 1.2:

  • Run Renoise (thanking you or whoever fixed the bug in the previous version which made it crash 9 times out of 10)
  • Assign an instance of Rainbow 2 to an instrument
  • Select a preset
  • Tweak it until it sounds the way I like
  • Compose the song
  • Save the song (the song still plays right at this point)
  • Load the song
  • The song sucks because all my tweaks are lost and the instrument sounds like the preset. If I make a sound from scratch, it will sound like the first preset (presumably because the preset selection is saved together with the song).

I don’t know if Renoise 1.2 doesn’t save the tweaks (I haven’t tried loading a 1.2 song in 1.11), but I’m pretty sure it doesn’t load them, because any song made with Rainbow 2 in Renoise 1.11 sounds “untweaked” in Renoise 1.2.