Waves VST Automation compatibility Problem

i don’t know where to put this.

there’s still this bloody bug left with which renoise v2.0 cannot load vst effect parameters from a renoise v1.9 song correctly.

i’ve just found another song of mine, saved with v1.9 which has incorrect
vst fx parameters when loaded in v2.0 …

this time it’s OhmForce Ohmboyz of which the fx settings haven’t been loaded correctly.
but if i load it in v1.9 and copy the vst fx settings to clibboard and paste it to the same
vst fx of the same song in v2.0, then the settings are fine again! weird!!!

before that it was waves morphoder of which the automation parameters were set incorrectly.
instead of voice1,2,3 renoise v2.0 has loaded other parameters / values.

but that bug happens when saving it from a rns to an xrns. (just did it again, with v1.9 AND v2.0 … with both the automation parameters are fucked!)


correct automation parameters

incorrect automation parameters

also, renoise v2.0 isn’t able to load/understand Antares Filter v1.01 anymore, v1.9 does! :blink:

ofcource these bugs are all in v2.0. i haven’t downloaded v2.1bx yet
as i can’t use / download it anymore… :angry: :drummer:


I think I tried to explain this in the 2.0 bug reports forum as well:
Automations in VST are applied by index - they can else not be uniquely identified. This means as soon as the plugin gets updated and they start to add parameters “in between” the old ones, existing automations will no longer match. Theres unfortunately nothing we can do to avoid this.
Many VSTs get around this problem by adding parameters at the end of the list only. Or by releasing a brand new version which is no longer compatible with the old version.

The only thing you can do here is installing the old versions of the plugins again.

Antares Filter crashes in Renoise 2.0 while getting loaded. I have absolutely no clue why - well, I have also no clue why this worked before. Those are no longer developed, so we also can not ask the plugin devs for help - sorry…

so if it’s a problem with the plugins being updated, why do they still work when i load the RNS file?? … they are all there when i load the rns file,
they are just messed up when saving to an xrns file. weird stuff :P

the plugin hasn’t been change since years.

the same with the ohmforce ohmboys plugin. the device parameters are wrong when loading a v1.9 xrns into renoise v2.0.
the parameters are all correct when loading it into v1.9 !!

and with antares Filter plugin. that’s very weird that it wont’t be recognised by renoise v2.0 anymore. have you changed anything particular in the vsti loading or something? :open_mouth:

Are you using the same VST paths in Renoise 1.9 and 2.0? Probably you’ve got several Wave Shells installed and 1.9 picks a different dll than 2.0? In your exampl pictures the parameter layout is differnet.

Are the 1.9 songs correct if you load them into 2.0, but then are wrong as soon as they are saved&reloaded by 2.0?

Would be great if you could give us some example files. I can’t really follow the what was saved & loaded where anymore.

yes, i am always using the same VST folder. i sure have severall waves shells, but every shell is for extra plugins.
that means, waveshell 5.0.0 won’t load plugins which waveshell 5.9.5 is loading and verse visa.

the song is .rns … if i load it either in 1.9 or 2.0, the automation parameters are correct!

if i THEN save them in either 1.9 AND/OR 2.0, the automation parameters are incorrect!!

that means, they get wrong as soon as the song has been saved as an xrns.
maybe renoise 1.9/2.0 save informations in a different way or so??

i think i have given you that file already… OhMy5.rns … or so …??

What happens if you “Upgrade” the song in the song properties prior to saving?

Do the parameters stay okay right after upgrading, or do they get out of league right after the upgrade?

There might be something playing in that area…

they stay ok right after upgrading, but get fecked when i save it after i’ve upgraded it.
they get as fecked as on the picture above… weird stuff, eh!!