WIN: Fatal VST Plugin Error [Daedalus VSTi v1.12]

Hello![font=arial, verdana, tahoma, sans-serif,]
Since Renoise version 2.8 ([font=arial, verdana, tahoma, sans-serif]both x86 & x64 versions, and i guess earlier) this plug-in doesn’t work - Renoise displayed error message and plays no sound[font=arial, verdana, tahoma, sans-serif,][font=arial, verdana, tahoma, sans-serif]
[font=arial, verdana, tahoma, sans-serif,]
[font=arial, verdana, tahoma, sans-serif,]
[font=arial, verdana, tahoma, sans-serif,]
[font=arial, verdana, tahoma, sans-serif]16-preset version can be downloaded free from [font=arial, verdana, tahoma, sans-serif,][font=arial, verdana, tahoma, sans-serif]

Renoise 3.0 Final
Win7 x64 SP1

I can’t reproduce the problem on my Win64 bit version, but on the other side, i never had the plugin before.

The new version pops up with a nag-screen, perhaps something there goes wrong, perhaps the plugin tries to write or access the registry to check registration data (couldn’t find registry traces so far though)
Have you tried to start Renoise with admin rights and then start the plugin?

I’m always logging under one and only user “Administrator” ;)
Also tried overriding “Run as Administrator” ))) Same error

vV do you have any sound played with downloaded plugin?

Yeps, even with the nag screen on front. No problems either when switching presets.
Also tried turning on or off some options in the plugin properties (can run in multicpu environment, static buffering, etc) and then attempted to close and reopen and it does work fine.

We could look at the secondary obvious causes, like videocard drivers. (Renoise still needs DirectDraw and so does the plugin as it seems to me)
Not sure what NVidia driver revision you are at, the 335.23 are my current which work fine.

same for me ) but something “wrong” with my PC setup, i guess. All Nomad Factory plugins not working either ((( in log.txt all Nomad Factory plugins are FAILED ( it must work in demo mode without authorisation

All other plugins works fine. I guess it can depends on cyrillic symbols in my %USER NAME%. But i wont experiment on this: all other thing going good on my PC ) Perhaps, i must give up and switch to MAC )))

This plugin seems go wrong in any hosts (FL, Reaper, Mulab-32bit, Renoise) on my Windows 8.1 64bit PC.

4952 daedalus.png

I got the same error message in the first post too.
So you had better to nag to the author of this plugin if you really need it, though he might be a free-time developer.

Rather I wonder why it works on the vV’s PC… :huh:

win8.1 x64 works fine…

Special characters in foldernames are tricky indeed… Satobox, perhaps same problem with Kanji?
Perhaps it is something that could be fixed in Renoise as well, if perhaps the shortname of the path is used.

Ahh, no, my %USER NAME% is “satobox”.

Also, I usually use the VST folder at C:\VST\32bit .
Today I’ve tried C:\Program Files (x86)\Vstplugins , but still it didn’t work.

Renoise is rather better than other hosts since the GUI of daedalus is shown in Renoise (but no sound).
In other hosts, I cannot see even GUI.

I guess that any Synth Edit module causes something wrong, maybe.
The author of daedalus discribe that "This software (Daedalus VSTi) is provided “as is” without warranty of any kind. ".
So, I suggest to use an other VSTi… :unsure:

Btw, his VSTi “monolisa” works fine here. But his name isn’t shown correctly in the VSTi list.

4959 daedalus.png

Maybe the author’s name causes the problem on the localized win OS ??
Or, the Nag Screen is the cause, maybe.

Lets forget it ) was just wondering why it didnt work ) looks like i’m not the only one, who experiencing some problems with some plugins

What about Nomad Factory? )

It seems no problem.
I’ve tried the demo of Liquid series and Rock Amp Legends, and all work fine here.

any Nomad Factory is FAILED for me (

The first one then at least also excludes space characters in folder names, but that problem would have popped up a long time ago if it were in there.
(one of the first things i check when working with files)