Windows 10: Screen starts flickering badly while using renoise

I’m using renoise 3.2.1 on windows 10 on my laptop and lately after loading some plugins and running it for a while my screen looks like it’s having a seizure . I got the flickering when the cpu and ram weren’t even near max load and it happened running it on both the integrated intel graphics and the nvidia geforce 940mx card also on the laptop.

Dell Inspiron 17-7779 laptop’s specs: intel i7-7500U cpu, 16gb ram

The weird thing is I can game on this laptop and I don’t get the flickering happening, I’m very confused as to what is causing this. I ran a game for 2 hours on the nvidia card and it was fine.

To me it could sound like symptoms of a broken monitor. Try testing if it happens while using an external monitor.

Well I just tried to see if it would happen only displaying on an external monitor and the same thing happens.

The screen always goes back to normal upon reboot which is why I’m confused as to why it only seems to be freaking out while I’m using renoise.

There’s an option in the Preferences under the GUI tab for “More compatible gfx updates.” I would try that and see if it makes a difference.

Had the option set by default it looks like.

Didja try turning it off then?

Set it to off and it still happened.


I would recommend updating the laptop drivers, but I don’t even see anything relevant on the page:

Yeah I had updated my graphic drivers for the whole laptop to see if that would help but it doesn’t seem like it has. My brother thinks maybe the cpu auto-overclocks itself while renoise is in use and renoise doesn’t like that so it freaks out. I have never once touched overclock settings at all but I have seen his computer blue screen of death on 2 programs consistently because he had his computer set to overclock.

Try turning that off, see if that helps

I already had it unset.

Well shit :smiley:

If the computer is overclocked, have you already tried running it at its regular speed?
Audio processing can be very demanding to the CPU.

I looked through my BIOS and I don’t have any overclock setting, the only thing that comes close is the standard behavior that I’m fairly sure is default since I bought the computer in 2017. There’s the intel turboboost which is set by default but there’s no cpu clocking options whatsoever in my BIOS.

Actually so far turning off the turbo boost may have helped. Haven’t seen it throw an issue yet. A friend said this is a windows 10 display issue that affects intel and nvidia chips. I’m likely to think that is the case because when I ran linux on this laptop I never had that problem the only reason I went back to windows is because linVST stopped working for some of my windows VSTs.