Windows: TesslaSE VST plugin fails to open/won't load


(TZer0) #1

Today, I am suddenly unable to load one of my favourite plugins (effect) - TesslaSE. It worked yesterday and I can’t see any applied updates to the OS in my update log.

I am running Renoise 3.1.0 final on a 64-bit Windows 8.1 with 8 GB RAM, an i5-4570 and and an NI Komplete Audio 6 for soundcard.

Here’s the log: http://pastebin.com/zaQqTHRL

Error message shown in GUI: http://i.imgur.com/WrvyEAs.png

Plugin - can be found here, but their dropbox-account is overloaded, so I’ve taken the liberty to upload the file to my own site here (this is freeware).

I’ve tried the following debugging steps:

Moving the file -> does not work

Moving the contents of %appdata%/roaming/Renoise and rescanning everything -> does not work

Trying all the various settings in the VST Plugins-section in Renoise -> does not work

Renaming the file -> “works” - however: this breaks all the links to my plugin in all the tracks I’ve ever made, making this fix somewhat useless.

Launching the plugin in Renoise 3.0.1 -> works

Does anyone know where else Renoise might store information about plugins/things that may affect plugin loading?


(TZer0) #2

FIXED thanks to ijsf (who suggested checking the registry)

I opened regedit, found HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers by searching for TesslaSE.dll and removed the key inside.

What the fuck, Windows?