Wrong Main Outputs - Motu Ultralite

Hi guys;

Have been using Renoise for years, and all of a sudden it has complete started doing something weird - it thinks that the Headphone 1 & 2 outputs of my Motu Ultralite are the main outputs; so whenever I load a song it is now playing it through the headphones and not Outputs 1 & 2. No other host application is having this problem, so I’m a bit perplexed. Is there a setting somewhere in the config that I’m missing that dictates which outputs are the main outputs? As it stands, things aren’t working.

The Ultralite is working perfectly under OSX, so I’m quite sure it’s not a problem with the unit.

Maybe you have set the headphones as the masters routing and then saved this song as template song? Have a look at the “Preferences/Misc” page please, if there is a template song set. You can also delete it there.

Or have you maybe changed your default routings in the “Audio & MIDI Setup” OSX preferences? Could you please check if everythings correctly set there. -> /Applications/Utilities/Audio MIDI Setup.app

Routings can be changed in the mixer. Enable the “Out” switch at the bottom right of the mixer to make sure that you see the track->soundcard channel routings. Then check the master tracks routing setting.

It’s not a song template issue - older songs that played normally otherwise are now playing through the headphones. I see the main outs in the master drop down, but they are never selected by default. It’s quite odd. I will check the Mac routing settings though - great idea, thank you!

Messed around with everything and even reinstalled Windows entirely. Phones 1 - 2 still show up as the master outputs in Renoise. Very odd. I can’t really figure out anything else to try here; and as I said in the OSX version of Renoise this issue doesn’t occur, so I’m scratching my head a bit - this is clearly a Windows only issue. I will use Directsound instead of ASIO for the time being as that way I can pick the main outputs. Any other ideas would be appreciated.

My setup is:

Macbook Pro (Santa Rosa chipset) 2.4 GHz
MOTU Ultralite

running Windows XP SP2 via Bootcamp
(and OSX as well obviously)

All the best,


What happens if you temporary rename your config folder in your Documents and Settings\username\application data\Renoise\1.8 to something different and restart Renoise?

Hmm, that didn’t change anything I’m afraid. Thanks for the suggestion though!

Renoise chooses/stores the used routings by index, so the problem is that now (because of whatever reason) your headphones are at the first channels in ASIO.
Renoise can not influence the order, just gets it by the ASIO driver. The first channel is usually the main out, thats why its also used by default…

Is there some kind of routing/controlpanel tool where you can order/priorize the ASIO channels?

What happens when selecting “Limit to stereo I/O” in Renoises ASIO preferences? Are then just the headphones available?

Could you please post the log.txt section where your ASIO channels get enumerated/activated? Maybe this help me to find out how this could have happened.

Absolutely - will post the log as soon as I get home. When I click ‘limit to stereo in / out’ it selects ‘Phones 1 - 2’.

There is nowhere that I can set the ASIO output priority in the settings of the Ultralite. Thnaks for the help, guys - more soon!

Here’s the log from startup and then shutdown:

Version : Renoise V1.8.0 (Feb 27 2007)
Date : 2007-06-28
OS : WinXP Service Pack 2

Application: Initializing the API…

QuickTime: Initializing…
QuickTime: Initializing QuickTime (QTML) FAILED (QuickTime might not be installed)…
QuickTime: Initializing QuickTime (EnterMovies) FAILED (QuickTime might not be installed)…

GraphPort: Initializing the Font Engine…
GraphPort: Initializing DirectX…
GraphPort: Checking the DirectX version…
GraphPort: Obtaining and configuring the DirectX interface…

MIDI: Enumerating MIDI devices
MIDI: Opening UltraLite
MIDI: Opening Microsoft GS Wavetable SW Synth
MIDI: Opening UltraLite

Application: Init…

VstPlugs: Trying to instantiate C:\Program Files\Steinberg\Vstplugins\WaveShell-VST 5.0.dll
VstPlugs: Instantiate OK (uniqueID:0)
VstPlugs: Releasing C:\Program Files\Steinberg\Vstplugins\WaveShell-VST 5.0.dll…
VstPlugs: C:\Program Files\Steinberg\Vstplugins\WaveShell-VST 5.0.dll was released
VstPlugs: Trying to instantiate C:\Program Files\Steinberg\Vstplugins\WaveShell-VST 5.2.dll
VstPlugs: Instantiate OK (uniqueID:0)
VstPlugs: Releasing C:\Program Files\Steinberg\Vstplugins\WaveShell-VST 5.2.dll…
VstPlugs: C:\Program Files\Steinberg\Vstplugins\WaveShell-VST 5.2.dll was released

Application: Creating a new document…

Player: Constructing…
Player: Attaching to the document…
Player: Start running…

GUI: GUI is constructed

Application: A new document was created.

ASIO: Initializing
ASIO: Trying to open ‘MOTU Audio ASIO’
ASIO: LoadAsioDriver … OK
ASIO: Using SampleRate 44100
ASIO: postOutput = true
ASIO: FillDriverInfo … OK
ASIO: InputBuffers: 12, InputChannels: 12
ASIO: OutputBuffers: 14, OutputChannels: 14
ASIO: Got kAsioSupportsTimeInfo
ASIO: Got kAsioSupportsTimeCode
ASIO: BufferType : 0
ASIO: OutputLatency: 523, InputLatency: 568
ASIO: CreateBuffers … OK
ASIO: Up and running

GraphPort: Initialising in WindowedMode
GraphPort: Successfully initialized

Application: Init OK
Application: Enter MainLoop…
Application: Exit…

Player: Constructing…
Player: Attaching to the document…
Player: Start running…

GUI: GUI is constructed

Shut down: Released the old Document
Shut down: Stopped and released all MIDI-Devices
Shut down: Stopped the Player

ASIO: Stop Polling…
ASIO: Releasing MOTU Audio ASIO…

Shut down: Stopped and released the active Audio-Device
Shut down: Destroyed the Player
Shut down: Destroyed the VST Host
Shut down: Destroyed the Window and all Views
Shut down: Destroyed the Document
Shut down: Saved the preferences

GraphPort: Releasing DirectX…

Shut down: Destroyed the GraphPort
Shut down: Destroyed the Preferences
Shut down: App is down

Application: Exit OK
Application: Finalizing the API…

MIDI: Closing UltraLite
MIDI: Closing Microsoft GS Wavetable SW Synth
MIDI: Closing UltraLite

The log looks ok.

Have you already contacted MOTU for support? There somehow must be a way to redefine the ASIO channel setup.

Do other ASIO applications on windows also show the “Phones 1 - 2” as the first channels?

just a pointer:

Only Renoise is having this issue, to be clear. I can contact Motu, but the Motu is working fine in OSX and in all other Windows ASIO applications, so although the problem may indeed be the MOTU, it seems particularl to Renoise. It’s not the end of the world; I can use the Directsound settings in Renoise in the interim, but it would be nice not to have to. Thanks for all the help guys.

I meant: Are the headphone channels in all other apps also the !first available channels?
Maybe they somehow skip them when assigning the default routings. Then we should do this as well.

For all new songs, you can now simply save a template song with the master routed to the main channels instead of the headphone channels. This wont override the settings in old songs though…

That’s what I mean; the main outs are being selected as the main outs in all other apps. In other words, the only program in which the MOTU is not behaving as it should is Renoise. I will keep trying things to get it to work though and will post back with any success.

I seem to have confused you: When selecting routings in other application, are there the headphone channels the first entries in the list of the available channels or are they the last ones?

No, they are not the first entries in the list in any application other than Renoise.

Taktik -

I’ve done some digging and it looks like this is a MOTU issue. I’m finding out if there’s a way to “reprioritize” the Main Outs, as a recent firmware release to the Ultralite seems to have changed the order of outputs in the Ultralite’s Scheme, and now Phones 1 and 2 are the default outputs.

Thanks for the diligence - this is a ‘nobug’ at this point, or at least ‘buggyhardware’.

You’re welcome. I’ve moved this topic to “help and support”: Let us know as soon as you found a way to remap the channels. Other MOTU users will have te same problem…

The final word from Motu is that this cannot be changed. So any Motu Ultralite user will by default have music playing through their headphones, and will have to manually change it to do otherwise. Bad design decision by Motu. If you have two setups, one with a different ASIO soundcard, the outputs will have to be changed every time - for me, I will have to change the output routing on every single song I have, because they were all written on a Motu 828 mkII which has ‘proper’ audio routing (i.e. the main outputs are the default output).

Anyhow - that’s the final word!

weird stuff …

… to me, i didn’t know i can set the output routing at master. was wondering where its hidden lol. cheers!