Xrnx Packing (Distribution) Woes

I’m trying to package Nibbles. I’m getting the same issue as Duplex and Rubberband on OSX when testing the package. That is, when I drag and drop, nothing happens.

My packaging is as follows

$ zip -r Nibbles.zip com.renoise.Nibbles.xrnx/  
 adding: com.renoise.Nibbles.xrnx/ (stored 0%)  
 adding: com.renoise.Nibbles.xrnx/Bitmaps/ (stored 0%)  
 adding: com.renoise.Nibbles.xrnx/Bitmaps/cell_black.bmp (deflated 17%)  
 adding: com.renoise.Nibbles.xrnx/Bitmaps/cell_blue.bmp (deflated 17%)  
 adding: com.renoise.Nibbles.xrnx/Bitmaps/cell_yellow.bmp (deflated 17%)  
 adding: com.renoise.Nibbles.xrnx/main.lua (deflated 74%)  
 adding: com.renoise.Nibbles.xrnx/manifest.xml (deflated 40%)  
$ mv Nibbles.zip Nibbles.xrnx  

At this point I drag and drop the file and nothing happens. However, If I drag the folder it works.

I’ve tried many variations (underscores, removed the xrnx in the folder name) but it’s not working.

What’s up?

You must pack the folder CONTENTS, not the folder itself. So the manifest.xml is in zipfile root, not in subdirectory.

Doh, thanks. That worked.