Zebra2 starts to late if auto suspend is enabled

If you enable “auto suspend” for Zebra 2.8 VST macos, the first appearing note will be played a bit too late. Maybe this is related to the PDC Zebra itself has, so maybe PDC for VSTi wasn’t taken into account so far?

I’d recommend that you don’t use auto suspend with Zebra. Zebra is complex and can take some time to process sound data. Auto suspend interrupts the process and creates short delays as you’ve discovered.


Sure, but maybe it could be fixed, the idea was to include VSTi latencies, maybe Taktik has overlooked that aspect.

Perhaps. I’ve found that if I want complex sounds from Zebra2 in Renoise, I render them as samples and use them that way. It works really well. For simpler sounds, Zebra2 shows no latency issues or I use Zebralette if I don’t need the complexity of Zebra2. I’ve always considered Renoise to be a “sample based tracker” first and vst host second so I suspect the optimizations are oriented towards sample-based work.

There may be an additional way to lessen the latency by configuring the CPU thread priority at the OS level.


Good for you, nice everything works for you. It does so for me, too.

But I mainly consider renoise as a vsti tracker, I barely use samples at all, except for drums. I also like to add random modulation to sounds. If I use many instances of zebra (I almost do every time) , the auto suspend is quite a lot saving cpu. So I am interested in a nicely working suspend for zebra. Also I of course can add workarounds to make it work properly, and my world will not end, if it doesn’t work properly.

Render in place is no option for me, since I have too less discipline to split up Composing and mixing into two really separate work units. Quite often I get ideas from unusual happenings while mixing, actually. Instead I live to keep the project as flexible and live processed as possible.

1 Like