[2.8B5] Where Are My Renders?!! (Lol)


Trying to render an old track of mine using Renoise 2.8b5

While it’s rendering, if I alt-tab and look at the folder, I can see the files are there, 0 bytes long (still rendering) but once the job is finished (it says it’s completed) the files are gone.

I’m doing a multi-track render, each track to a separate .wav file but the same thing happens when I do a regular render.

Any ideas?

Renoise will create temporary files for each track during the rendering process, but some of them will be cleaned up afterwards when the render is finished. It simply depends on your song, how the tracks are routed, etc. You can’t really rely on the temporary files you see during rendering.

Does your song use send tracks quite heavily? If so, any tracks that contain a send device with ‘mute source’ enabled will be merged into a single render for the send track (it doesn’t make much sense otherwise).

If you suspect there’s some other weird thing happening, it would be helpful if we can get your song’s .xrns to run some tests.

Thanks, I’m grabbing the latest beta to test, will check the sends, I’m pretty sure I deleted all the sends I was using since I’m doing a complete re-do on the mix but I’ll double check.

Are you definitely looking in the folder you have set and not a temp folder? Have you tried searching for the filename of the rendered file?

Also: B6 is out ;)

By the way, I forgot to ask: Do all the files disappear when the render is finished, leaving you with absolutely nothing? Or do you still get something rendered, and you simply noticed that certain temporary files got deleted afterwards?

Okay, beta 6 worked perfectly fine, phew! I’ll report back if I catch the bug again but perhaps it was just a glitch in b5.


Yeah, all of them vanished.

I did notice that, while it was rendering, if I alt-tabbed, then copied one of the files to say, c:\temp and played t, it was completely silent, nothing was rendered to the file and I did try with several of the wavs.

The song did have sends however, I deleted all the send devices, I just had the empty, unused send tracks but they weren’t receiving any signal.

but b6 worked perfectly.

And yes, I did check the folder I set as the render patch and I even searched for *.wav and sorted by date on both my HDDs ;)