A question about perhaps background caching with regards to VSTs

I have a unique issue which I wonder if anyone can provide some insight into. Certain VSTs I use in Renoise are doing something such as cycling a sequence of modulation at a certain rate. It seems like when I reload the Renoise track, the cycle does not reset to the same start point, and it kind of ‘endures’ over reloading the track or restarting Renoise, however will reset (I think) upon restart of PC.

Does anyone know if there is some kind of ‘flush cache’ function in Renoise or have any suggestions towards my described issue above. Thank you in advance for any replies.

IF you’re able to reset the start point of the modulation through the vst, you could potentially use the formula device to modulate that parameter with y=PLAYING to get it to sync with song playback using an “instrument modulation device” with that parameter as the target
Not sure if this would work, but seems like it should.
y=PLAYING is useful for syncing internal fx devices to song playback, so it seems like it should work. worth trying in any case

2 Likes

Thank you for your reply zensphere I will experiment with that function you mention.

1 Like

Hello zensphere, I have added the formula device, I have typed in y=playing to its formula list, but you will forgive me for asking, could you describe in slightly more detail the specifics steps in using y=playing function, as if I am a n00b who has not used the formula device before? A key point is that the modulation rate changes regularly throughout the track (It is a sequencer rate), so if I put it as y=playing as 1 on that parameter as the target, the modulation rate becomes fixed throughout the track at that speed from what I can determine.

Hmm… What is the vst and what is the parameter you’re aiming to sync/modulate?

Wondering if there’s another way to go about this :upside_down_face:

Hello Zensphere, the vst I am using is Cherry Audio, ps-20. It is a synthesiser based on korg ms-20 but it also has a sequencer. The parameter on that plugin I am modulating is ‘Seq-rate’. This parameter adjusts the rate of repeat of a short sequence of notes (8 steps). As a matter of interest, this is a track that uses only one instrument and depends on alternating the rate of that sequence to create the song, perhaps a bit like a didgeridoo.

My issue arises out of trying to create harmony through that sequence of notes in the vst, and the notes I am entering in renoise. Each time I play my track again in renoise, the sequencer in the vst is out of step with the notes I have entered in renoise. It is almost bizarre to me and I cannot figure out why it’s happening.

Hope that’s not too much info, thank you.

  • Edit, perhaps I should mention that I am using *instrument automation to draw envelopes that apply to the ‘seq-rate’ parameter of the vst.

ok, I don’t have the ps20, so might be shooting in the dark here…
you have the sequencer sync switch activated, yes? How does the rate param interact with that? Is it free running or then tempo synced when sync is active?
you could try using a formula device with y=PLAYING to set the sync param on the ps20 to force it to renoise’s clock, but I would think the vst behavior would operate this way by default…
another approach might be to use a hydra device to set specific tempo synced seq-rate values on an instrument automation device, then trigger the hydra automation, so you know you’re then getting the precise values that you desire at those times.

in an ideal world, you should just be able to set the synced seq-rate param with an instrument automation device, and it would work

flying blind here, but these are things I would try. I’d guess a lot of it depends on how the vst behaves internally

1 Like

It sounds like you want to automate the start/stop parameter of the ps-20 sequencer. If you insert an “Instr. Automation” meta device on the track, you can find the “Seq-Start Stop” parameter in the lists. PS-20 is looking for value of 0, then 1, for each start or stop, so a start and stop is actually 4 events.

In a little testing the only reliable way to reset the PS-20 sequencer from the start at the beginning of playing the whole song is to insert a 1 line sequence before the start of the song, with a value of 0. Then on the first real sequence of the song use a value of 1. You will have to manually stop the PS-20 sequencer from the plugin window before playing from the start of the song. The start of the song should look something like this
Screen Shot 2022-07-08 at 6.29.05 PM
Screen Shot 2022-07-08 at 6.37.45 PM

there might be a better way but this works

2 Likes

Thank you zensphere and kingdoobie for the replies above. I will experiment with your suggestions and report on the outcome.

Edit: A brief reply on the above,

It has led me down some rabbit holes, but I must say the fix of using the seq-start-stop parameter of “0” in one sequence before sequence 1 of my actual track where I enter “1”, created some unusual outcomes. It certainly had an effect on the issue I am dealing with, but did not “fix” the rate as such. One effect that it has, is some how, in seemingly random alternation, to turn on or off the actuation of the sequencer in the vst at the beginning of playing the track, including rendering the track. Quite possibly I have to mess around with its settings more to figure it out.

I also find it interesting that in the seq-start-stop parameter, the value is not fixed at binary “0” or “1”, but can include shades of “1.25” or “1.6” etc, and I wonder what effect this has on the track.

As for the suggestion of the hydra device by Zensphere, I have found this device interesting and am still trying to figure it out. I just felt like giving some kind of update, thank you gents.

1 Like