[ACPI powersettings]Renoise - Jumpy Graphics

Very strange. Just started my newly download Final version of renoise 1.8 and loaded a song. I started to edit it and noticed some staggering and lag when i moved around with the Arrow buttons. PLaying the song it’s the graphics seemed to lag too around in around 2-3 seconds intervals holding for half a sec or so at some times. I thought it might be the VSTI’s but then i started a new song and tryed again. With a blank pattern just pressing play it did exectly the same thing…

I opened the task manager and went to the performance tab, and could actually see the spikes of the CPU usage jumpign between 3 and 23% … even when the song was stopped…

What can be causing this?? It never did like that before.

I reinstalled all soundcard drivers and graphics drivers but it doesnt seem to dissapear. It doesnt do anything to the sound but laggy patterns is just sooooo annoying… especially when editing… any solutions?

I tryed different settings in the Audio tab in the Renoise preferences, but nothing helps…

plz help me out here

EDIT:!! … As well i can see the Renoise Process in the Task manager jumping from top to bottom on the list when sorted by CPU usage… is this normal behaviour even when Renoise is stopped and not playing anything???

2.0 Ghz Core Duo Laptop
Mobility Radeon x1600 graphics
100Gb Hard drive…

I just installed it on my work computer to see if it’s the same problem there. but NO. When stopped, and no song loaded i don’t get the spikes i get on my laptop. I’m even more confused now? What can be causing this on my laptop, that should be performing as well as my stationary work PC, with about the same specs…

… hmmmmmmm

Hi Lareux,

Sounds strange.

Could you send me (taktik @ …) your log.txt file? You will find it in: x:\Documents and Settings%username%\Application Data\Renoise%renoiseversion%

This might give us a hint of whats wrong.

Renoise 1.5 runs fine with the same setup?

Do you have a Hyperthreading CPU on your laptop? And if you do, does the taskmanager show both cpu’s enabled? (checked) when you check Renoise’s cpu affinity for that process?
How much audio-latency did you set Renoise to, how high did you set your framerate in Renoise? How is the behavior between full screen and windowed mode?
What model is your laptop, a Dell? Do you have an Intel Chipset? If so, Have you tried installing the Intel Accelleration application? (Also see http://tutorials.renoise.com/?n=UC.HickUpsCPUSpike )

Problem solved. There’s no more stuttering of the graphics. I re-installed software that controls the fan. My laptop has 3 fan modes, Normal, Cool, and Silent. Don’t know wich one was activated when the above problem happened, but i know that there are some settings that will reduce the CPU clock speeds when using “Silent mode”. Maybe that was the problem. I just re-installed all the laptop drivers and software and problem solved itself. I can try duplicate it though. I think it was the fan speeds, and the settings in that software caused the trouble though.

There’s also similar settings when using the battery. Possibility to reduce clock speeds to save power. and when using that i noticed almost same thing. A song that usually used around 40% of the CPU according to the CPU percentage in Renoise, used 80% when playing a song when i didn’t connect the AC adaptor. But this just changed the overall CPU usage, not just making the graphics lag.

Probably because of Intel SpeedStep feature that clock down your cpu to save power.
That can of course be turned off as it is really never recommended to use with any music application :)