Aftertouch/CC Tracker?


I was wondering. I can map/change some parameters for ‘live’ use, using the Key Tracker and Velocity Tracker. But I actually wanted to use my aftertouch to make realtime adjustments. Is there anything like Aftertouch Tracker, or more generic, CC Tracker? I was not able to find it.

I want to map my aftertouch range 1-127 to a midi control CC range 70-127 so that I can use aftertouch to modulate some FX on my synth.

Note this is purely meant for midi routing and has nothing to do with the pattern editor.

Kind regards,


“Posting in reverse” - I answered your question by creating a preset you can use:

You basically can run a tool called xRules as an intermediary between the controller and Renoise. This means disabling it in the Renoise MIDI prefs and enabling them in the tool instead, so the tool can take over the MIDI input and rewrite things.

After installing the tool you can load the preset by choosing “Add” > “Locate file” (I think that’s what it’ called :stuck_out_tongue: ).

Once the built-in file browser appears, choose the folder “examples” and load the file “aftertouch - cc”

Like I mentioned, you will need to have your controller enabled in the tool Options. Also, once you have loaded the ruleset you will need to specify the name of the port that the ruleset should be listening to.

Once it’s working you should see the usual “MIDI indicator” lights blink (upper right corner in Renoise toolbar), and from then, it’s just a question of mapping the synth parameters.

A couple more words on the xRules preset:

  • Aftertouch messages are turned into CC#1 messages and then passed on to Renoise
  • Any “non-aftertouch-message” will be passed on to Renoise, unaltered.

Notice also that you don’t have to load the “ruleset” every time you start Renoise (see Options > Autostart).

Hi Danoise,

Thanks for taking the time to build this. Today I finally got around to trying it out. Unfortunately, I cannot get it to work.

So hopefully you can help me further.

This is what I did so far:

  1. Installed xRules

  2. Opened Renoise

  3. Went to preferences, midi, removed my midi keyboard (arturia keystep) from the ‘In Device’ list

(now when I press any key on the midi keyboard, no light blinks on the top right)

  1. Went to xRules

  2. Loaded the aftertouch - cc preset

  3. In options under Midi Inputs, I enabled my arturia keystep.

(when I press any key on the midi keyboard, still no lights on the top right)

  1. Under input, I changed the last field after the WHEN parameter to ‘keystep’

  2. Under Convert, I changed the script to output 0x69 (CC #105, which is the filter frequency on the novation a-station)
    (still no lights on the top right)

  3. I went to renoise midi channel and selected my audio interface output and selected channel 5 (which is where my a-station is)

Now no logging is shown on the midi OUT pane, the midi IN pane still shows the logging from the keystep. But no lights flash in the top right.

Am I missing something? Do I need to configure xRules as a renoise input somewhere?

Kind regards,



Additionally I found out that when I create a new rule from scratch and add WHEN channel IS EQUAL TO 1 and then press any key on my midi keyboard, I see the round midi connector symbol inside xRules blinking. I do not see that blinking when using the Aftertouch - cc preset. Even after selecting my correct input port…

Thanks, it’s helpful that you’re so detailed :slight_smile:

I think, from what you write, that you still need to specify which input port the ruleset is applied to.

In the first rule - Convert - I’ve added a check for the MIDI input port name. You need to select your controller here as well.

I added this to prevent the aftertouch conversion to apply to all active inputs for the tool, but you could leave it out, of course.

I think it’s set to the unit I used for testing - Remote SL MKII.

I think you mean the port selection on the “Input” page, not the “Convert” page. I cannot find any port setting there…

And yeah, I already did that… without result.

BTW I’m on Windows 7. not sure if that helps any.

Also while fiddling with xRules I found a few bugs I think. Sometimes I could not select an option from a dropdown (port) it kept switching back to the first option in the dropdown, until I removed the entire rule and added it again… but it’s still a 0.x version eh :wink:

Oh, yes, I meant the ‘Input’ rule of course.

But, weird, it’s working perfectly here.

I don’t thing the OS has anything to do with it, I’m on Win8.1 but can try with another machine too.

Btw: just so you know - the small MIDI button lights up only when you’re outputting MIDI.

It complements the Renoise MIDI indicator, as that one won’t show direct MIDI output from a tool, once from Renoise itself.

And you’re right of course, there are plenty of opportunities to improve this tool (would be cool, e.g. if that MIDI indicator looked like it’s Renoise counterpart).

Sometimes I could not select an option from a dropdown (port) it kept switching back to the first option in the dropdown

Couldn’t make it do the same thing, but I know I have experienced it once or twice.

Would be great if you could somehow make this reproducible and explain how :slight_smile:

I use this trick to map aftertouch to anything, without an external tool:

  • take a sample-based instrument and map aftertouch to its input level
  • use a Signal Follower to detect the volume of a track dedicated to this instrument
  • map the output of the Signal Follower to an Istr. Automation or an Instr. Midi Control device.

There are several little details to make it work flawlessly though.