All of a sudden , poort performance when recording from pc keyboard


(gentleclockdivider) #1

All of a sudden , renoise is behving really poor and laggy when recording realtime from the computer keyboard
Recording 16/32 th notes while spectrum analyzer is on , the recording becomes poor and laggy …doesn’t matter if I use vst instruments or midi out
I am using an intel i5 with dedicated amd graphics card …


(gentleclockdivider) #2

Restarting the pc didn’t help , hiding the spectrumanalyzer neither
I had this issue in the past on a single core laptop and the solution was to disable the time out in renoise config settings ( for recording mode ) .

I changed the record batch time out to 0 , but it always changes back to 500 (after saving the config file ) and restarting renoise ?1


(Raul (ulneiz)) #3

I have no idea of your problem, but have you saved the file with Renoise closed?

I think that some concrete effects can generate subtle delays. Are you using effects on the tracks?

Also make sure that your CPU is not working too much on another task outside of Renoise.

What is RecordBatchManeuvertimeout exactly for?


(gentleclockdivider) #4

All of a sudden it works again as normal , and the config file didn’t change .
The batch manoever timeout is for undoing whole /large recorded sections in the pattern editor in one go , hence the timeout value .
Setting this value to zero equals undo note per note


(gentleclockdivider) #5

@ developpers >
Could someone please tell me why the 'timeout 'in the config settings is not applied
I set it to 0 ms still it always changes back to 500 ms ( see screenshot )


#6

Did you try Raul’s advice?


(gentleclockdivider) #7

Yes , I have
I am waiting for one of the developers to chime in


#8

So I assume that it didn’t/did work for you and/or you want to know why Renoise overwrites the config.xml file on exit from taktik then.


(gentleclockdivider) #9

Exactly