Anyone On A Mac? Where Is The Ins Key?

renoise says this is a short cut for creating a new pattern. i can’t find it.

http://tutorials.renoise.com/Renoise/RenoiseShortCutKeys
Read the upper paragraph…

unfortunetly that didnt prove very helpful as my "fn’ key does nothing and when used with the ‘cmd’ button just starts the pattern as normal…

You have a MacBook?
And a MacBook probably does not have a help key?

(I must add, that the keyboard info on the help-page has been provided by Mac-users.)
Any Mac(Book) user to the rescue here?

MacBooks don’t have a ‘Help’ key, only the standard Apple keyboards have it so you might want to assign you own key combination…

assign is the way.

do i have to assign my own key within leopard? or within renoise?

The insert key is where it would be on a standard PX keyboard. Thats usually the “help” key when you have a full size keyboard.

On Mac laptop keyboards there is no such key, so either assign your own keys, or use the predefined secondary keys: The Renoise keybindings on the mac usually have some extra secondary Modifier+Backspace bindings for those who have no insert key…

Why should they when osx is that easy to handle :P (sorry I’m an osx lover)

none of this has been of any help. all keys explained here do not create a new pattern in renoise. is anyone running renoise on a 2007 i-mac here? what key are you using?

Go into preferences and assign your own key(s).

ok, i went into renoise’ preferences, found a bevy of options, re assigned my numlock key to insert new pattern, now when i hover over the insert pattern button it says “Insert a new pattern instance [numlock]” but when i press the numlock key nothing happens.

this is getting more and more bizzare and deeply confusing.

I don’t think [numlock] can be a key. Try changing it to something else. I just tested my assigned keys (not numlock) and it works for me. Use a modifer like Shift/Option/Apple maybe? (i.e. Shift ~ maybe?)

Also, make sure you have an orange border (when using the default blue theme, four corners of orange) around the pattern editor. This indicates the “zone” you are working in. You can switch zones by Option-Clicking on a macintosh. Practice by selecting the file area, the sample bank, and the pattern area to see the zone changes (keep the Option key pressed down as you click into a new “zone”). As this is not a GLOBAL key, your shortcut key won’t work unless you are in the right zone.

zone? i just tried all of what you said and none of it did anything. i think my mac is a freak. i just assign shift ~ to my insert new pattern key and still it didnt work. i have orange corners around the pattern editor regardless of which ‘zone’ i’m in.

i’m gonna go cry a little.

ok, i just tried that again and now i get what your saying, this all makes perfect sense and now my my insert pattern key works, but i dont see the point in having a short cut key to use a command that you can only use when you click with the mouse into the right zone, when you could just click on the insert new pattern button, or am i missing something…?

GLOBAL shortcut keys can be used from anywhere. Check the preferences, the dropdown that led you to Pattern Editor also has GLOBAL. Those are keys that can be used anywhere.

Insert Pattern isn’t global. Maybe you can make the case for why it should be? I don’t see why it should. Why would I want to add a pattern, blindly from the sample editor, for instance? I can only see myself wanting to add a new pattern while in the pattern editor.

EDIT: The reason for this is that there isn’t enough room for all shortcuts to be put together in one place, so they need to be partitioned in zones. The advantage is you can use the same shortcuts for different things when in different “zones”.

Granted!!! however, if i am in the pattern editor zone and i want to use my keyboard “shortcut” to insert a new pattern, i have to hold alt and click with the mouse in the pattern sequencer zone to use it, when i could just click on the insert new pattern button, thus making the keyboard shortcut a longer way round to do it.

this makes no sense for me.

What version of Renoise are you using?

In version 1.9.1 when I go to the pattern editor it’s selected by default. (The big thing that looks like an excel spreadsheet taking up all the space, that’s the “Patten Editor”, not the thin column on the left, we’re talking about the same thing right?) and the keystroke works, by default.

I only have to use option-click (edit: middle click works too) when i want to select smaller windows like automation grids and the sampler?

Edit: What mouse button are you using to select stuff? Left button is normal select, middle button is option-click, right button is context menu. Check that your mouse settings in OS X Preferences aren’t weird.

i’m also using 1.9.1. my middle click works as you have mentioned, but the shortcut doesnt work when i’m in the pattern editor (the big thing in the middle). if i middle clikc in the pattern sequencer (thin columm on the left) the orange corners come up and i can use my insert pattern short cut.

in this case, i take it we are talking about the same thing.

That’s bizarre.

The shortcut [Insert a new pattern instance] works for me when I’m in the [Pattern Editor].

I don’t have to middle-click the [Pattern Sequencer] for it to work.

Maybe someone else can chime in?

EDIT: Renoise -> Preferences -> Keys -> Dropdown -> Pattern Editor -> Pattern Sequence… You assigned your [Insert Pattern] shortcut there, right? Not in the Pattern Sequencer, right? :)

sir you are a saint. i was assigning the right command in the wrong menu. problem solved.

thanks alot for your time, this is definetly gonna improve my work flow no end, and now i know my way around renoise preferences alot more i can see myself adding other shortcuts to speed things up.

big up.