Asus Xonar DG 5.1 ASIO problem

I’ve recently bought an Asus Xonar DG 5.1 cheap, to use for ASIO, but Renoise displays the card’s ASIO settings as 16 bit and 10ms all the time, in the ASIO Control Panel popup window, and those values are greyed out and can’t be changed. I downloaded the FLStudio 11 demo to test that out, and that shows the settings correctly (even though they are also greyed out) - I set it to 32 bit, 1ms, using the Asus Xonar ASIO control panel, which I access from the taskbar thingy (the up arrow in Windows 8, I don’t know what that particular ‘thing’ is called), just to see how my i7 860 would cope, and it plays back the FL demo songs flawlessly, which is pretty impressive, and when I go into Control Panel in FLStudio, it correctly shows the settings are 32bit and 1ms. Is this likely to be a bug in the ASUS drivers (which is what I imagine it is, because I don’t think the ASIO drivers are a strong selling point of the Xonar DG), or is it something that can be fixed in Renoise?
I set the latency to 80ms so that I could hear there was a delay in FL Studio, but when I went into Renoise, the delay was gone, and it sounded like it was at 10ms latency again, and Renoise still showed 16 bit 10ms in the ASIO Control Panel, in spite of the fact that the ASUS Xonar ASIO control panel showed 32 bit 80ms.

No big deal if this can’t be fixed and it’s an ASUS problem, I’m still very pleased with the card for £15! 1ms latency in FL Studio is pretty damn impressive!

I suspect that if the card shows 32 bit in its own controlpanel, you may assume that 32 bit is correct it it may falsly identify its bitrate towards Renoise.

You could perhaps try to A/B comparison the audible results by using very high pitched frequencies, let Renoise render them in 32-bit mode and then listen to the audio in an application that reports 32-bit audio and compare that to how Renoise plays it in 16 bit.
Very high pitched and squeeky sounds easily get disturbed in lower bit-rate settings because of a lot of loss in detail during the conversion.

Hi vV, I’m not really bothered about the 32 bit part, I am only concerned about the latency, as some of my songs had problems playing back in Renoise at 10ms latency, with some crackling, and it seems like FLStudio can handle a lot more than Renoise’s can with this particular card - but this is just the feeling I get from using the FLStudio demo songs at 1ms latency, and then playing a few songs of mine that use some CPU heavy patches (like some of Spire’s).
The ASIO control panel is greyed out in FLStudio and in the Asus ASIO control panel too, when FL Studio or Renoise are open - so ignore that bit from my previous post, it’s just the way it works. It’s odd that Renoise has chosen 10ms as the latency, and it definitely overrides the Asus ASIO control panel when I’ve set it to 80ms.

Renoise doesn’t choose the latency or any other properties of the soundcard it’s ASIO settings, it gets these figures from the card driver itself, but perhaps there may be something wrong in the communication, but whatever happens in the background, only the devs can tell here. You also mentioned Windows 8 -> Current Renoise build wasn’t compiled for Windows 8 so it seems to become pretty clear some analysis has to be done to straighten up issues on Windows 8 as Windows 8 has been reported not to be the same as Windows 7.

Yes, there are some differences with audio on Windows 8 compared to Windows 7, it’s no problem anyway, it still works okay, I just wondered where the ASIO control panel was getting 10ms latency from every time I opened it in Renoise. Maybe the devs can shed some light on it.

Hello! I had similiar problem with ASIO + Xonar + Renoise. It seems to be specific Xonar + Renoise problem.

But i have found a workaround. To change ASIO settings in renoise, you have to manually disable Xonar in Windows Device Manager, then enter Renoise (it will throw some error, ignore it), enter Renoise prefenreces, choose ASIO,Xonar once more, click ‘Control panel’ and you’ll have soundcard settings editable. You can change them to whatever you want, quit renoise, re-enable soundcard in device manager, restart renoise. :huh: