Audio crackles when moving mouse over certain GUI elements


(Juno) #1

Hello fellow Renoisers and Renoise Devs,

I have this issue on my previous and current studio computer.

Whenever I’m moving the mouse over the GUI, over certain elements, I have crackles in the audio. At first I thought they were random, but I noticed a pattern. It’s whenever the mouse moves over from van GUI region or element to another.

For example, when I move the mouse cursor from the scopes, over to the main tracker editor, when I crossover the border separating scopes and editor a crackle occurs. Likewise when I move towards the file browser, FX editor, the dragbar to the right of the main editor.

So it seems to be triggered by moving over a visual boundary.
Or is it still related to the audio driver somehow ?

I have this issue on two separated machines;

Specs old studio computer;

  • Intel Core i7-4770
  • nVidia Geforce GT 630 Silent video card 2GB VRAM
  • 8GB RAM
  • Sandisk 240 GB OS-Software SSD
  • 2 x WD Black 1TB hard drives
  • Windows 7

Specs new studio computer;

  • Intel Core i7-8700k
  • Intel UHD 630 integrated graphics
  • 32GB RAM
  • 500GB SSD for OS-software
  • 500GB SSD for VST-audio
  • 2TB Seagate hard drive (projects, audio)
  • Windows 10 Pro

Common on both machines

  • Firewire 400 PCIe addon card with texas instruments chipset (legacy driver)
  • 2 x Motu 828 MKII FW audio interfaces
  • Dual monitor 24" LG setup connected through HDMI

The Motu drivers used : MOTU Audio Installer v1.6.73220 (Release Date 2017-07-01) (latest available) and ASIO is used in Renoise.

The crackles occur always, no matter if buffer is set at 128 samples or 1024. Also happens when CPU load is really low, for example using a simple VST plugin which only uses 4% CPU as displayed withing Renoise.

I’m a bit clueless, this computer is a beast of a machine. Even the integrated graphics is more than adequate for my usage. But even with the previous machine with a discrete graphics card I had the issue.

It only happens in Renoise. When I’m using Reaper for example or Sound Forge I don’t have this issue.

Is it something that is triggered because of the way that Renoise renders graphics ?
Still audio(driver) related ?
Thus I have to buy new audio interfaces ?

I already tried playing with the settings in Renoise regarding the GUI, but no difference (more compatible gfx setting, FPS setting, …)

It would be a big investment to buy new audio interfaces, and I would hate to have the same issue after buying new interfaces. I don’t have any spare external interface lying around (with different connection type than firewire and different brand/drivers) so I can’t rule this out at the moment.

I’m a bit clueless right now. And it’s sometimes really annoying. It sounds like the audio is clipping sometimes, but it’s just related to this movement over elements. But certainly annoying when mixing / mastering, where you move around a lot.

Any ideas or pointers are really appreciated!


(Juno) #2

I forgot to mention that on both machine I already tried to play with the appearance settings of both Windows 7 & 10 (from best to more performance). Same with processor scheduling. This makes no difference. And still only happend in Renoise not within other software.


#3

A shame you can’t try another external soundcard/driver.

Quick question: Safe to assume you don’t get any crackles running Renoise through the onboard motherboard sound card (apart from the usual computer noisy hiss that pretty much everybody gets generally doing that)?


(Juno) #4

Hmmm, yes I have been thinking about that (using the onboard crappy sound chip).

Only issue is I really need to try it on the “old” system first then. The new studio machine is built into the studio furniture with ongoing active projects at the moment, and it’s a tough job getting to the “not necessary” connections. Everything else goes to patch panels and stuff like that, but onboard audio doesn’t (it’s even disabled in the BIOS).

But then again, I’d have to test it through DirectX instead of ASIO, or I have to install ASIO4ALL, but still, that might cause other issues. Or it might not behave in the same manner since it’s not ASIO or an ASIO driver And on the “production” system, I don’t like to install the ASIO4ALL stuff, just in case something breaks, or the license managers think this is a HW change and invalidates licenses.

I was hoping somebody else was noticing the same issues as well. Or had similar issues with a FW interface or a MOTU interface in general.

I know these interfaces are getting old. They still do the job. Yes I’d like to upgrade, but it costs a lot of money as well and without being sure that the issue is gone - aside from having the money - it would be awful to get the same issue after spending a lot of money.


#5

Okay, the only other bit of advice I can think of is to also keep in mind the background tasks/services in Windows that are running (common to both machines.) Try and kill all unnecessary ones (a bit like super super clean safe mode I suppose). There might be a particular combination you’ve come across between Renoise, your audio interface driver and a particular task. Got to rule out as much software as possible, good luck :slight_smile:


(Juno) #6

Already been down that route as well (daily systemadmin / netwerkadmin job, so I know a few things about diagnosing :wink: ). I don’t even have antivirus running or anything else on the production machine. It isn’t allowed on the internet as well (unless I need cloud activation for a VST license / update or something similar).

Even on quite different machines it happened. Win7 vs Win10. Clean setups, just renoise, reaper, soundforge and all my samples, projects, VST instruments and fx. Nothing more, nothing less.

Maybe I’ll try to shoot a short video tonight as well, so the issue is viewable and you can hear the crackle while I hover the mouse over the GUI elements. It’s like the audio render stops for a millisecond or something like that, very strange. And in other software I don’t have this issue, but my main workflow happens in renoise …

I also monitored latency, all is well, I’m alway in super low microsecond latency values that show up as “this machine is perfectly capable for realtime audio”. Well, with these kind of specs, I’d go nuts if it wasn’t :stuck_out_tongue:

It’s a bit frustrating.


(Raul (ulneiz)) #7

First of all I want to ask you if your speakers are active. If your speakers are active, do they use grounding?

If so, there may be an interference in the amplifier of your speakers, which is derived from the usb ports of the motherboard through the grounding of your household electrical installation.

If this is the case, the immediate solution is to disconnect the ground connection, in your speakers. A 2-contact adapter would suffice.

This problem usually occurs in active monitors, which are not well isolated with grounding or are low cost. What model of monitors do you use?


(Juno) #8

Not grounded, and even when using grounding, had the same issue.

Yes active monitors (Yamaha HS5, Even BAS 20/20) headphones amps etc, but the crackle is there only when I move the mouse over certain GUI elements. Tried headphones on headphone amps (with, without speakermanagement system on), on mixer, on phones output on the MOTU828, always the same. And don’t have this in for example Reaper. The crackle almost sounds like a disturbance in audio render for a millisecond, while rendering something on screen when hovering over elements in the Renoise GUI. It also isn’t USB noise or anything like that (BTW, I’m using 2 firewire interfaces, no USB connected there).

So I think I can safely eleminate typical USB, peripheral or grounding noise, sizzle, popping, … .

And looking at the picture, I really can’t list every piece of kit I have in my studio, this is only about half of it …

I’ll try to shoot a small video tonight after the daytime job so I can show and let you hear it only happened when crossing elements/regions in the Renoise GUI …

Thanks for thinking along already !

studio%20juno


(Raul (ulneiz)) #9

Superb studio location! If it is not grounding, try changing the refresh rate of the Renoise GUI. If your mouse drivers allow you to change the USB frequency, try changing it to see if the crunch changes.

I only have to suspect that there is some small derivation between the integrated graphics card and the audio monitors.

By the way, the Yamaha HS5 do use grounding (the rear connector is 3 contacts (AC IN)). It is not like this? Surely the problem is not the grounding?


(Juno) #10

The studio is on purpose not grounded because otherwise I have groundloop issues between equipment.

But as said, even directly connecting headphones on the MOTU I have this crackle whenever I hover / move over certain elements / regions in the GUI.

In renoise, as I said earlier, I already played with the “more compatible gfx” settings, ticked the FPS settings checkbox off. Tried turning it back on and gradually increasing from 5 fps to the default 60. Always the same issue.

Same issue on the old system with the nvidia gt 630. Drivers are completely up to date (no more recent drivers downloadable)

I also looked at the latency monitor while hovering around, didn’t notice any spikes.

Tried several wired logitech mices, 2 types of microsoft mice (one is a 4500 for sure) wireless. Nothing changes.

It really gets triggered by the gui. In the main tracker editor, you have a scrollbar / dragbar on the right. When I hover on it, it changes color (highlight) then it crackles. Hover away, highlight goes out, crackle.

When hovering in Reaper over GUI elements I don’t have this issue. So I don’t know if it’s something in the screen render that messes up the firewire or audio driver stream or vice versa.

Thanks for the studio compliment. There are only 2 problems. When everything is in there, I barely have room for myself, and even in the winter, without heating I can easily reach 26 to 28°C :wink:


(Juno) #11

Ok,

So I made a quick video about this issue with my smartphone, so the audio quality isn’t great, but you’ll hear the crackle for sure. Asio config set at a measly 44.1kHz / 512 samples (which is huge). Everytime I move around at some kind of “boundary” in the GUI you can hear the audio crackling and stuttering.

Suddenly I also noticed that certainly in regions where the “drag” mouse icon appears instead of the regular mouse pointer the issue is most noticeable. It doesn’t happen when moving over the scope/track windows only, or moving in the tracker editor section. But as soon you make a crossing there is that darned crackle/stutter again.

As you can see, CPU usage isn’t sky high : 20 - 25%. And the latency monitor doesn’t show major latencies as well …

What is triggering this ? On 2 of my machines ? Is it really the firewire card / motu interface ? But what has audio to do, with a mous moving over a visual region ? :confused:

I hope a developper perhaps can shine some light on this issue :confused:

Youtube crackle demonstration


(dblue) #12

Can you try using DirectSound instead, to see if that behaves any differently?

I also noticed this right away in your video: It seems to bug whenever the mouse cursor image changes. Very odd indeed.

One thing to try: See if fullscreen mode behaves differently? You can toggle it with Alt+Enter (or via the View menu).

Edit: Found another post online describing a similar problem with mouse cursor changes causing drop outs. This relates to USB, but I wonder if it might also affect FW interfaces: https://superuser.com/questions/1137033/usb-lag-when-mouse-cursor-changes


(ffx) #13

Did you now try the onboard audio, like 4tey suggested? You do not need to compare it with the old onboard system, just this system, onboard vs firewire.

Here 3 more ideas:

  • Put the firewire pcie card into another slot (will change irq)
  • Search for a more recent driver by googling for the chipset only
  • If it doesn’t help, disconnect the 2nd motu, so only one is connected directly to the workstation, no serial usage

(Juno) #14

Ok, so first the things I tried;

  • DirectSound on MOTU : Same issue (tried even with insane high latency setting)
  • Fullscreen (ALT + Enter) mode : same issue (funny how only the main display is full screen btw, the plugin/instrument window is still windowed on the second monitor)
  • Despite of having iLOK and other license manager might break, I enabled on-board audio in BIOS, installed drivers : On-board audio is same type of crackle/stutter. (Hell didn’t break loose, like I had in the past, but quickly I disabled the on-board crap again.
  • Firewire PCIe card move : didn’t dare to do this : tickling the licensing managers once with HW changes was enough :stuck_out_tongue: (I still do have to get projects finished due to deadlines).
  • Chipset driver is already the latest from Intel. Was one of the first things I already did.
  • The MOTU interfaces weren’t connected serial, and despite same result with on-board audio, I still tried disconnecting one : stutter is still there

After resting a bit - I’m not at thin guy (anymore) - everything is racked, yes also the computer is built in a 19" case, so I had to remove 7 preamp - busmixers to create a hole where I could barely fit in, so I could plug in my headphones directly in the on-board audio to check. Removing the computer wasn’t an option at the moment due to cabling and other studio furniture, synths, etc … .

So there I was, huffin’ and puffin’, looking at the other option / link dblue posted.

I was like, “how can this fix anything, instead of 1 pointer, a few are shown with some delay”. But I thought I give it a chance anyway, I had this issue since the previous decent machine, which partly got replaced by this beast due to the crackling, but it wasn’t as noticeable on that machine, you’d still hear it, but for some reason this machine was more prone to it. After years of struggling with this, thinking “the old machine can’t handle my projects anymore, video card is outdated, etc”, I gave it a shot.

And forgive my typing this while I shout :

I DON’T HAVE CRACKLING / STUTTER ANYMORE

Yes, I got “seasick” from staring at the trail, but how much I tried, the stutter wasn’t there anymore. How weird. I have put the trail on shortest possible setting. No trail is visible, the only thing you can see it that the mouse cursor doesn’t moves as smooth anymore, but that’s fine by me if it solves this. It’s really odd as well that when you turn mouse trailing on or off it really takes a fair amount to do so. So I really wonder what is getting changed by this. In the link that was posted, it didn’t seem clear as well.

I was fiddling around, yes, I can still get an occasional crackle, but only when I go with a lot of CPU hungry VST instruments playing, and going under 128 samples @ 44.1kHz sampling rate. But 4.4ms delay is fine for me. Even on 88.2 an 96kHz all seemed fine until I started pushing this beast. So yeah, probably due to age of MOTU drivers, firewire in the loop, and then the mouse issue.

I’m so happy I don’t have to buy new audio interfaces at the moment since funds are thin at the moment. But still I wonder what triggers this and if it could get a fix or workaround in an update perhaps.

So I’m going to mount all preamps again and put cabling back, get me some painkillers (long story, I’m a pain patient since an operation went bad years ago, and bending myself into corners didn’t help it either, so I need my phase 2 painkillers at the moment) but it was worth it, when I have this result !

Thanks so much for your help.

I still have another issue with some waves plugins, at the moment I have a work around using sandbox mode however, and that’s something for a new thread, when I have no deadlines to meet for this audio project.

Thanks all for thinking about this issue and trying to find a solution !

One more question though : I can’t remember what default options were set in the GUI preferences. It’s set lik you can see below at the moment. But what is the best setting ?

image

And for those wondering : yeah, I managed to fit my not so young and slender self through this glory hole :stuck_out_tongue:

20190123_222632_2


(system) closed #15

This topic was automatically closed 12 hours after the last reply. New replies are no longer allowed.