AudioDamage Quanta - Inf db clicks and dropouts (windows 10 VST3)

Anyone else using Quanta in Renoise? I’ve just started encountering a serious audio glitch, and I have no idea what might be causing it. Occasionally there will be extremely loud clicks that will completely top out the meters, regardless of track volume. My project is only using about 25% CPU. This happens in both the VST3 and VST2 versions. It also happens both during playback and rendering.

Here’s what a rendered Quanta track looks like. You can see the clicks that are much louder than any of the other audio. These dropouts appear completely random and unpredictable.

Screenshot 2021-09-13 20.12.38

That is odd. I use the VTS3 Quanta v1.21 in Renoise 3.3.2 in windows 10 Professional and have never encountered this. If you can reproduce it in a sample Project to upload I can see if it happens on my system.

Sure, here’s the quanta track from the project I was working on:

quanta test.xrns (942.2 KB)

Thanks for checking it out. For me the glitch usually happens within a minute.

I let it play through at least twice and then rendered to disk. Pulled it into Audacity. No clipping, no glitches. I’m not sure what’s going on on your end. If you can think of anything for me to try on my system let me know. Seems like I may not be of much help as I cannot reproduce the behavior you’re seeing.

image

The only thing I can think of is…

Too much latency for the plugin?
Not enough latency for the plugin?

Try setting your latency in between 40 and 175 msec.
(menu Edit… Preferences… Audio tab)

Sometimes, when setting a too large latency (for example: 400 msec) some plugins may stutter / hold.

Sometimes, when setting a too small latency (for example: 6 msec) some plugins may stutter / glitch.

You may also want to experiment with the Static buffer setting:

in the Plugin tab, press the three-bar stripes button under Plugin.

image

I almost forgot about the plugin settings. I enable the “Use Static processing Buffers” and disable Auto Suspend.

I vaguely remember having some erratic behavior with the static buffers being disabled.

Thanks for the replies, both of you.

Latency was set at 41ms when using my laptop’s internal audio (DirectSound) and 11ms when using my interface (ASIO). I’ll try different latency settings, but I suspect it won’t change anything since the glitch also happens when I’m rendering to disk. I’ve had dropouts in realtime audio when the latency is too low, but this is different. These spikes are much louder than any of the other audio.

I turned on static buffers. Doesn’t seem to male a difference. Auto-suspend was already disabled.

Anyway I’ll keep trying things. I’ve emailed Audio Damage support, hopefully I’ll hear back from them.

Update: I’ve now got the same glitch happening in Reaper. So it’s not a Renoise-exclusive issue. I’ll keep trying with AD support. :man_shrugging:

I am having the same issue with this plugin (VST2 & VST3) basically since its initial release
(tested on Windows7 and WIndows10).
As far as i can tell it mainly occurs when using very short attack or release times in the FEG section.
It also happens sometimes when switching presets - but less often since version 1.2.
But from the changelog i cannot tell why that is.

Are the clicks you’re getting loud enough the clip the master track?

Here’s a screenshot of the rendered track in Reaper. The audio item volume is turned all the way down. These clicks are still audible, and still visible, meaning they’re infinitely loud.

Screenshot 2021-09-19 15.41.31

I can’t upload a wav file here, but I’ve included that section rendered to a sample. Just to show the nature of the glitch, and how loud it is:

Warning – Turn down your volume before opening this!
Quanta Render.xrni (841.3 KB)

Yes they are.
Looking at your attached file, the burst pattern is different from the static bursts i experienced.
It might have something to do with the “sidecar” oscillator but that is just a wild guess.
Eventually the developers have to be made aware of this.