Auto Adjust Seems To Not Be Working With Effects On Master

hi,

i’m running izotope ozone on master and it seems auto adjust won’t work when it’s enabled…
i’m on 2.8.0

thanks & regards,

unhammer

Auto-adjust or auto-normalize? Forgive me if i have overlooked something but i don’t know any specific native Renoise function on the master track named “auto-adjust”
Well, if i guess you speak of auto-normalize, make sure you don’t have the auto-gain or soft-clipping option turned on.
Another thing you might want to change is the track headroom in the “song settings” tab to 0DB.

sorry, a bit unclear :) it says “Auto adjust (lower) the master volume to avoid clipping” when i hold the mouse over the button right to main volume in the top left corner.
you’ll find the same function on the master tracks Mastering section (at the end of its dsp chain), it’s called “Auto Gain” there.

if i max the master volume, enable ozone and then enable “Auto Gain”, it doesn’t lower the volume as much as it should, i.e. it still clips.

The auto gain adjusts itself after clipping, just like the auto normalize feature of ozone (If i understood that one correctly) you need to run the full song through it to get a final adjustment. The next time you play the song clipping should then no longer occur.

i know how it works :)

when ozone is turned off it lowers volume correctly to avoid clipping each time it occurs (like it should).
when ozone is turned on it will set mastervolume slider to 0db if it has been set higher, but no further than that.

0db --> volume slider set to 0db
<= 0db --> no action taken

and let me clarify that when i’m talking about 0db i’m talking about the volume slider, not the actual output.

i’m watching major clipping with auto gain on right now…

[Edit]:

“> 0db --> volume slider set to 0db”

slider set to 0db seems to have been a coincidence.

it seems to me the auto gain function will adjust the post fader for the volume at the start of the dsp chain, not at the end of it as i believed it did.
is this expected behaviour?

i’ve tested with renoise’s native maximizer and a vst now, in addition to ozone. i get the same behaviour.

It looks like Ozone then does what it promises, auto adjust the levels to not go higher than 0dB then the autogainer also have no reason to go lower.
Correct me if i’m wrong…The autogainer doesn’t seem to affect the post volume at the start of the chain since enabling Ozone obviously influences the signal (at which Ozone is then at least positioned before the autogainer effect in the dsp chain)

Major clipping as in “way above 0db” or major clipping as in “the 0db bound is constantly touched”?

i’m not talking about ozone functionality, i’m only talking about renoise’s autogainer.

let’s say i have a perfectly adjusted output when i put ozone, or some other maximizer (i’ve tested with a couple others), in the master dsp chain.
then i use it to boost the signal. this is where i expected the renoise autogain function to adjust the output slider accordingly.
it looks to me like it doesn’t do that. it will adjust the output somewhat, but i get clipping.

as in way above 0db when i try to :)

it’s no biggie really, i just wanted to let you now. i know how to adjust it manually :)

When ozone is set up to clip, it’s output will never go beyond a certain point (0dB) and thus the master volume will never go below a certain point (0dB) with auto gain enabled. Same applies to Renoises Maximizer device, which also is a hard limiter.

Using auto-gain simply does not make sense in combination with hard limiters at the end of the master FX chain, because the limiter already will make sure that the signal never goes above a certain point.

what taktik said, everything said by OP is incorrect because the point he’s trying to make is that once you have a maximizer before auto-gain, (and the maximizer thus will do the work of the auto-gain) the auto-again does not go below 0dB and that would be “not working correctly”. but that is the whole point of the maximizer, after that device (in default state at least) the signal never exceeds 0dB. so what the heck would auto-gain have to auto-gain against if there’s no clipping?
congrats with your 10x1337 posts btw taktik :D