Brickwall Limiter On Mst Track

It appears that - unlike in Cubase - putting a ‘Brickwall Limiter’ on the ‘master out’ (Mst) track doesn’t guarantee that the track will stay at or below 0db.

In Cubase, you just put a limiter on the out, and forget about it if you want to.

In Renoise, it looks like the ‘vu meter’ still pushes ‘into the red,’ even with a ‘brickwall limiter.’

I’m hoping that there is a really simple solution to this that’s gone unnoticed here. Is there some button or setting that can be pressed somewhere in Renoise, so the limiter - when the ceiling is set to 0db - indeed doesn’t allow anything to go above 0db?

Or is it that the little red light and above-0-db peak indicators are ‘pre-limiter’ and not reflective of the post-limiter signal?

Strange, works here. I put the Maximizer on the master track, set the ceiling to 0 dB and there is no clipping, no matter how loud I put the master (pre and post) volume.


The signal is being stopped at the clipping level.
TECHNICALLY, it’s being clipped, but it’s like setting the threshold to a lower setting.

After all, do you HEAR clipping?

After all, do you HEAR clipping?

yeah man… just same as i think :)
what you hear not what you see

Indeed, I don’t hear anything untoward happening, but that red light - and the peaks reading to be over 0db - is a bit disconcerting. It’s also interesting how others aren’t seeing this at all.

I’ve noticed that the red light blinks if you’ve increased the global volume for the song.

This issue has been brought up a long long time ago, regarding the Renoise master dBFS meter. I can’t remember the exact details of the discussion, but for my money the clip light can go on at -0.2dBFS depending on the shape of the transient. If in doubt, use a 3rd party plugin meter to really check.

Unless you’re mastering in Renoise, your mix shouldn’t be anywhere near 0dBFS. And even in mastering, you need a ceiling of at least -0.3dBFS to account for inter-sample peaking, sometimes lower than that again. Different limiter plugins have different qualities, and I think the Renoise Maximizer can only be push so hard before it breaks the song.

You should never be mixing and composing with a peak limiter on the master. You need to set your playback monitors correctly and mix with more headroom. For more helpful detail check out this article:

this might sound silly… but i just mention it anyway in case you didn’t realise, when the red led is blinking and you then put a limiter… you have to click the red led to reset it. also you could put another limiter after the renoise one… heh. ;]