Bug: Vol Command is ignored on added columns when using FX commands

Renoise 64bit - v3.4.2 (Apr 25 2022)
Windows 10 64bit Pro

While editing a pattern with highthat samples i noticed the volume command was not working on an added column in a track. Thought maybe it was because of the Rxx command. vol stayed at 100%

I moved the samples over to the left and the volume command works again.

I tried adding a 3rd column and moving them to the right again. Same thing. Vol is ignored.

When I remove the Rxx commands, now Vol works on every added column

I also tried moving the Rxx commands to a second fx column and the samples to the second note column. Seems to make no difference. it only works when the notes are on the first column.

This seems like a bug, FX commands should work for the line regardless shouldn’t they?

Can you please post an .XNRS song file that clearly demonstrates the problem you’re experiencing? That would be incredibly helpful to us…

I’ve tried to work through each one of your posted examples, just using a basic sample (a “highhat” as you said"), but I cannot seem to reproduce your problem…

The volume commands, the Retrig commands, etc… everthing worked as it should… Even when I move the note columns around and what not…

But I could be missing something completely obvious here… So…

Please post an .XRNS song that clearly demonstrates the problem happening from pattern to pattern, so that we can follow it, or do whatever else you need to do in order to show it happpening in a replayable fashion that we can make proper sense of.


Here. The just before the half way point the is an example where it works. the repeating notes at the very end of the pattern is where it does not work.
TEST.xrns (48.1 KB)

(Not sure if it embeds the samples. if you need them. Its just a couple hat samples)

ghost_train_test.xrns (46.0 KB)

Does this do what you had in mind?

Yes, That’s what I was trying to say. I works if I keep the notes on the first column, but it gets ignored on the 2nd or 3rd when there is an FX command present on the line for some reason.

I don’t remember this being an issue before, Maybe I just didn’t notice. There are times I keep the kick, snare, hats on the same track but separate columns and I tend to do fx a lot through out. just seems like its not working right. Like pattern fx commands should work on the line regardless of the column the notes live on. Right?

Edit: It seems to behave weird only when there are notes in the first column. If its an empty column it behaves as “expected?” Moving rettrig to sample fx works as expected regardless of first note column as suggested below.

If you press the “FX” icon, every column gets its own patterncommand fx slot added;

Does adding the retrigger commands here instead fix the problem? I think how it sounds in your example song file is how it has always been using the retrigger that way. Not sure if that is how it was supposed to be though? If you don’t know already, you can also input R5 in the (volume or) panning column.

Documentation calls it the Master FX column. It doesn’t say much about it, but seems to imply that the Master FX column should be affecting everything in the track. As when used on the Master Track, will affect all other tracks depending on the fx type (between samples/plugins).

I do know work-arounds, but im just trying to point out and confirm if this is a bug to hopefully be considered for fixing.

As one more test I used the Local FX columns and it works as expected, but interestingly, the Master FX column starts to work for all 3 of the Note columns. Between the first post and this test im getting inconsistent results.
TEST 3.xrns (266.2 KB)


In your song file, since the retrigger is in the Master FX column it will affect all currently playing samples. The note played at line 120 is tailing off but still actually playing when the R05 hits, so it also gets retriggered. Since it’s at full volume (and naturally louder anyway) it dominates the sound in the second column.