Can Prehear And Load Sample, But Not Play

I used to track using Impulse Tracker for several years. After a long pause I recently decided to start tracking again, but I thought that IT was a little outdated in the meanwhile.

At first I thought that the tracker scene was near death. I checked trackers like MadTracker, Buzz, Sk@le etc, but they just don’t work the way I want them to.

So I thought that I needed to switch to a non-tracker, and I expermented with software like Fruityloops, Reason, Ableton Live and others.

Anyways, recently I rediscovered Renoise, and that is exactly what I want… So I bought the software and started tracking again!

But let’s get to my newby question:

I have this wav sample that I can pre-hear and load. I also see the sample (waveform) in the sample-editor. But I can’t play it, nor do I hear the sound when inserting the sample in the pattern editor. The sample is one of the samples that came with Ableton Live, btw.

Is it possible that the soundquality is too high? Like said before, the strange thing is that I can pre-hear the sample. Some other samples from live work fine. And I doublechecked stuff like the volume, if there are any DSP’s connected, or if the track is muted or something…

Did you loaded the sample into slot 0 of the instrument?
Usually if you can’t hear the sample it’s because it isn’t mapped to the keyboard. If you accidentally load a sample into slot 01 of a new instrument, this slot isn’t mapped by default so that may be why you don’t hear anything.
(Also you use instruments in the pattern editor, not samples, think of FT-II instead of IT in sample-mode)

To map samples, click the slot and then select the key on the keyboard to assign the sample to it. (changing the basenote won’t do this)

Well, it has been months, and I was busy with other stuff like exams.
Finally I am able to “track” once again.

Still, I have problems with samples that I can hear in the preview, but can’t be played by Renoise. I might be wrong ofcourse, but I think that the mapping and everything is correct. For example, when I replace such a “bad” sample with another one, it will play in the pattern editor and everything works. I use a C4 Basenote, and tried to enter them in the editor as C4 notes… Without success.

Most of the samples that don’t work, are standard 44100 16bit stereo samples. They are ripped from an Ableton CD (Yeah, I tried some alternatives before I discoverd Renoise ;) )

The samples can also be played back in sound editors such as Adobe Audition, so they aren’t corrupt or something.

Ok, it seems like this must be user error… But hey, I am out of clues. To make life easier, I uploaded one of these “bad samples” and a screenshot:

Ah, thank you, it makes sense. When loading a working sample in an empty slot, nothing happens to the loop type; it stays on the default “none” value.

Indeed when loading a “bad” sample, the loop type changes to “forward”.
But I didn’t know that wave samples can have loops in the wave data itself?

Anyway, thank you for your help, and keep on developing this wonderfull peace of software ;)

I mostly have the “ignore loops” ticked under the config/import-section, might be easier than involving a second tool. ;)

I just encountered this issue with a whole bunch of samples from a Computer Music cover disc. The samples wouldn’t play unless I selected “Ignore Loops” before importing them, or went to the Sample Editor after importing them and dragged the End Point for the loop past zero (the loop type got set to “Forward” when importing these loops).

Is there any way to identify this issue in a file before importing it? Is the problem caused by someone creating the Loops in a particular editor?



You can mail the samples to “taktik at-sign renoise and the domain-suffix”. Not all samples, but i guess one or two samples would probably contain the same header-contents.
Once in a while some sample pops up with arbritrary loop-information in the header.
If you send it, it gets fixed.