Can`t Believe That Nothing Works Anymore (Midi Export)

I was just thinking about given renoise a try for a whole song, thinking about how to find a comfortable way to make a drum track and then…I was starting with an older demo-version (think it must be 2.0 or 2.1), was happy about using rpg for track-generation, song to midi conversion with xrns-sf, evrything fine. Then I saw the description about the pattern matrix in 2.5.1 and that was even better, so I installed the demo, made a whole song-construct with it (33 pattern evry of them generated as ONE BAR patterns because so I can change the chords directly in rpg) and then the mess starts. xrns-sf cant convert the 2.5.1 song to midi, 2.1 cant open the song and I cant find ANY way to at least copy the content from 2.5.1 to 2.1. Maybe a good joke but I find it hard to laugh about it....Didnt even find a notice that 2.5.1 files are not compatible with the older 2.0/2.1 version. Maybe someone has an idea though I really believe this is kind of ridiculous to develop a software in that way that nothing works anymore…

Richard

Yes, I do have an idea.

XRNS-SF is a windows front-end to a 3rd party suite of scripts, made for free as a hobby, by people who don’t get paid to do it.

It has nothing to do with Renoise.

It’s a thankless job where people bitch and make abstract statements about software development.

Here’s the Software Developement part: I fixed both the midi export script and xrns megre script for Renoise 2.5 files. My changes were committed to SVN several weeks ago but I didn’t bother to package it yet because frankly, it’s a pain in the ass. This is all available in the sourceforge revision logs and… meh. I’m assuming you aren’t reading at this point.

Here’s how you can fix the problem:

https://xrns-php.svn.sourceforge.net/svnroot/xrns-php/trunk/xrns-php/scripts/xrns2midi.php
https://xrns-php.svn.sourceforge.net/svnroot/xrns-php/trunk/xrns-php/scripts/xrns2midi_classes.php

In a text editor, open the PHP files and replace with the text from the SVN links above:

This will work with 2.5 files.

Good times.

Makes perfect sense.

Renoise can load all songs created in the version it is or any earlier versions.

The way the song is stored is revised and changed from time to time so to stop older versions of Renoise loading a song incorrectly you can not open a song made in a newer version.

This is the same reason that piece of software doesn’t work. Probably hasn’t been revised for 2.5.

You could try copy and pasting patterns between instances of Renoise. If that doesn’t work not sure what else might.

You can also trick Renoise into thinking it was made with an older version by editing the xml but obviously no guarantee that will work.

EDIT: OK see the good work has been done by Conner already, just not packaged for easy use by your average Joe. :)

For the record, there are no guarantees that XRNS-SF will work in the future. It’s not Renoise.

It’s PHP, so you could always fix it yourself.

I think you should calm down and have more realistic expectations :) . Opening projects made in the latest update in older versions of software almost never works. What would you expect with newly added features and specs the older versions simply don’t have/support? I bet it would be possible, but the time spend on backwards compatibility would mean less time programming on the cool stuff.

I think this was also mentioned by taktik somewhere, maybe even in the docs coming with the software, rather self explanatory imo.

Rpg still works here, though I have 2.5 installed and not 2.5.1, don’t think that matters though as the .1 update was because of installation problems on windows 7 if I remember correctly, so that should work for you too.

I’ve never used xrns-sf, but since this script and rpg are made by 3rd party you can’t really hold Renoise responsible if these refuse to work with newer versions, right?

Probably a matter of patience till the authors create an update.

edit: late to the party ;)

Sorry, there’s one more thing.

You’ll have to look for this line in the code:

  
require_once('midi_class_v175/classes/midi.class.php');  
  

And change the midi_class_v175 to the version you are using. (Or check out the latest version from SVN)

I will package for the average joe sometime in the future. The big issue is that I use OSX (not Windows, so the XRNS-SF isn’t me) and that I am busy dealing with a new baby. XRNS-PHP this is not my priority. If anyone else wants to do this, it would be appreciated. All the code is here:

Good times.

Dear Conner,

thanks for your advice and I am really sorry if you took my question personal because it was in no way meant in that direction and no critic to your wonderful tool. If there is a critic it goes to the renoise development because even without any knowledge of software-development I think it should be possible when you are not able to find an easy way (export midi directly from Renoise) to allow the people even one way to solve this problem. I was only a bit unfortunate that none of the three ways (opening in an older version, copy from the older version, export from your tool) works anymore. All my apologies too you, it was really not ment to critisize your wonderful work with that tool.

Richard

Yes, I agree, Hopefully MIDI export will be an officially supported part of Renoise in the future.

For now, sorry, this is what it is.

Dear Conner,

thanks again for all your work with that tool and your advice. And because I am one of the “average joes” (have heard that theres is something called php and might have something to do with programming…) I think I just have to calm down and be patient :-)))).

Richard

Dear Conner,

one more question, maybe you have an idea what went wrong. I tried what you said, loaded the two-script files in an simple text editor, marked and killed evrything, marked evrything in your links, copied it in the editor and then saved it. Then I changed the version from 1.75 to 16 in the xrns2midi.php (which is the actual version in the newest compiled version 1.07 I´ve downloaded and installed) in the line near the beginning. I´ve looked threw the rest of the text but could not find another part with these device in it. The same in the other script. Then I ran the application, it started, but when I try to run the script I get an error message “255”. Any ideas ?

Thanks in advance

Richard

Error 255 doesn’t say anything to me. Click the Show Console button, what does it say in there?

Each time XRNS-SF is mentioned, I’m reminded that I myself have a broken script in there (the microtuner one). I’ve basically decided not to put any more work into that one.

Conner_Bw is right about the nature of these external scripts - there’s no such thing as “forwards compability”, it really is an ongoing effort to keep them up to date.

Found it and fixed it :-)))) (first time I have the heart to edit in a script)

This was the error in the console window:

Warning: require_once<midi_class_v175/classes/midi.class.php>: failed to open stream: no such file or directory in C:\Temp\RENOISE_UND_TOOLS\xrns-sf-1.07\scripts\xrns2midi.php on line 68

Fatal error: require_once<>: Failed opening required ``midi_class_v175/classes/midi.class.php<include_path=.;C:\php5\pear`> in C:\Temp\RENOISE_UND_TOOLS\xrns-sf-1.07\scripts\xrns2midi.php on line 68

Seems to have something to do with this midi-class you mentioned

Fixed it in the line 68 and evrything works fine, I`m really happy, midi file looks fine to at first glance, thanks again :-)))

Richard

Next version, I should move unmaintained scripts to a “depricated” directory, or something.

Awesome, congrats. Nothing better than doing it yourself. :)

Hi Richard,

The only internal Renoise method to export MIDI is simply assigning each internal instrument to an external MIDI instrument in another host (Like Anvil studio) using Midi Yoke and then simply play your song and let the other host record the input.
That is, if the 3rd party plugins no longer work for exporting songs, then this method remains valid for as long as there is no official MIDI export option in Renoise.