Can this ImpulseTracker file be fixed?

Hi. For giggles I decided to ask here, maybe reduce my ignorance slightly. I am working on a project with an old tracker file. That would be the happy ending except that there’s some corruption in the pattern.

It’s pattern 2 on this file…

http://members.dslextreme.com/users/hwh/files/HKClub_Music.it

I was told to use schism tracker to interpret it. Ok. Pattern 2. I can play it, I can see the moment it screws up. And I have no idea how to fix it. I’m not a composer.

Row 48?? Sample is DLOOP3.WAV. And…

I don’t have a replacement for it. The idea was to replace the damaged section with a similar section, which wouldn’t require a tracker (although one is required to play patterns). But it seems to be a drum sample that is damaged.

I tried some sausagey fill-in of the time covering the damaged section, but that changed the tempo or timbre or whatever it is, it changed all the notes around which is a little astounding, that something seemingly unconnected to the rest of the arrangement would completely screw it up, but it does. That is, an audacity modified DLOOP3.WAV, same length. Plays back as expected in VLC.

Anyway I hate all this and just sort of want to confirm my diagnosis of no help unless someone here can wave a wand and cover it up cleanly.

Thoughts?

Thank you

When I click on your link all I get is this:

It seems to be a text document. What’s the tracker you used for this file?
Can you convert it into XM? This way you could play it via Renoise.

I just did a right-click / save as on the link.

The module is an impulse tracker which plays fine in Madtracker, even loaded into Renoise, the sample “DLOOP3.WAV” appears intact and error free and the module ‘mostly’ plays without error.

You can’t find the interruption I am talking about on pattern 2?

I downloaded Madtracker, played pattern 2, at line 48 DLOOP3.WAV plays (solo) and there’s a non drum noise in it.

Anyway…I think I have a solution. Somehow I pulled that sample out of the file, sausaged it up, and somehow replaced it. It doesn’t sound great, but I think less obnoxious than the original. What tripped me up is the whole song went nuts when I made this replacement in Schism Tracker. So I figured I edited wrong. But now it looks like it was just some weird issue in Schism Tracker - still not entirely sure if I was at fault, but since it works normally now it seemingly was a bug, not me. The file I made works normally in both programs.