Cannot Render In 44100 Hz


I just discovered that I cannot render (entire song) to 44100 at the moment. I simply cannot select the 44100 option from the drop down list, only the 48000 option is selectable. The is with 2.1.0 under (arch) linux under jack (running 48000hz - interresting).

Is there anything “normal” that can be done to allow the project to be rendered to 44100? Or is this a bug?

Any feedback appreciated.

I tried connecting to jack at 44100 and then I can only render in 44100. I can also switch to alsa/onboard sound card at 44100 while leaving jack running at 48000 and then render to 44100. But then I can only render at 44100.

In all: I can only render at the sample frequency I’m using for playback. Is this how it’s supposed to be? I thought it would be possible to select any sample frequency for rendering, disregarding what setting I’m using for realtime playback…

Hmmm, simply switching to another sample frequency seems to mess up (alt least some) vsti’s. I’m experiencing this with mdaPiano and mdaEp. They will be out of tune (untill I reload the song) probably because they’re getting their sample frequency setting at song-load-time. Is this a general problem with renoise or just 1) either those specific plugins or 2) because I’m under linux?

Also doing this dance back and forth a few times can crash renoise, making it hog the entire sound system with a single monotone, short-looped sound.

Well, you already noticed that some plugins don’t swap their frequencies if you change it in Renoise -> hence the rendering mode fixation.
I thought that the rendering fixation also had to do with the fact that the hardware-buffers of the audio-drivers were used, i had the same problems with a video editing tool that did the same.
I could do it if i started the software in its “Safe Mode”, but then i could not hear audio when i was editing and playing.

Perhaps Renoise needs a Safe Mode as well, but then would probably also need to reload the plugins or the song before rendering after a frequency change.

Is the fixation Linux only? I can select whichever same rate I want in the Render song section using XP.

Just discovered that I cannot change the “priority” either (always stays on “Low”. Could it be that this particular dialog is somehow broken/frosen under linux?

If you are using Jack, i believe you have to set the priority in the Jack console instead.
My Linux partition is screwed at the moment, so can’t check this properly.

atte: which linux dist, window manager and so on are you using?

Can you click & open the dropdowns in Renoises preferences dialog - does it there work as expected?