cant tell if glitch or operator error

So Ive just been getting started with Renoise, some artists I respect vouched for it so much I had to go with it.
But Im having some troubles that I dont understand because what Im seeing on my screen doesnt match the tutorial videos.
One - I cant load most vsts. I place them in C:/vst, and I have Renoise scan that directory, but only maybe 1 out of every 4 vst plugins actually shows up in the program under the “instrument settings tab” Im not sure if Im doing something wrong of if Renoise is just not compatible with many major vsti plugins.
Two – Im using my computer keyboard at the moment, and most synths wont play unless I hold down two or more keys. one key, I get no sound. two keys and It responds.
Three – when I press escape to “edit mode” I cant stop the track from scrolling and every space goes to “off” its like someone is pressing the backspace key continuously. If I press space once it scrolls more slowly, press it again and it scrolls hyper fast. I cant get any note to play longer than a fraction of a beat because it automatically goes to “off” on the very next notation space.

So Im not sure if Im experiencing a bug with the program, or if I just royally screwed something up. I didnt have these issues the first couple hours of using it, but they cropped up later, and now uninstalling and reinstalling the program still generates them.

One-I don’t know of any vst’s Renoise isn’t compatible with, and out side of midi-effects plugins like kirnu (which you can still load, you just can’t do anything with them) I’ve never heard tell of a vst that wouldn’t work with Renoise. That’s really strange. Make sure you’re not just overlooking effects VST’s in the DSP section, but if they’re all vsti’s they should all show up. Maybe try a different location that a folder in root, like the documents folder, if you’re using Win8. Also what windows are you on?

Two-I got nothing, that’s really weird. My guess though is whatever is causing your problem 3 is causing your problem 2.

Three-Do you have some kind of special key-repeating settings? Something like that is the only thing I could think of, if you’re trying to record live at least. Are you recording live or step sequencing? Because if you’re recording live it will record an off when it thinks you’ve released a note (unless you set it to not do that, but generally it’s something you want). If it’s doing that recording live then it thinks a key is going on and off and again when you hold it.

I also realized im using the 64bit version of the application, so that could be the source of my disappearing plugins. Ill try installing 32bit and see if I get the same issues.

wow, thanks for the fast response.
Im pretty sure Im not overlooking the vsts, especially since some show up and some dont. But I didnt think about the fact they may be 32bit only.
This is the first DAW ive worked with besides Caustic on Android (very simplified) I took one look at Cubase and wanted to give up, then some friends reccommended Renoise and I though : okay I can do this.

Not special key repeating sequence, at least not intentionally. Im on Win7 64bit and reason is the last 2.x release, not the new beta. If I cant resolve it soon ill upload a video, the program acts like its possessed. But since I dont really know what’s normal for it Im not sure, I thought the “holding two keys” issue could be a “feature” I just wasn’t understanding.

hah. but at least knowing that this isn’t normal behavior helps point me where to look for the problem.

32 bit plugins should still show up in 64 bit renoise, it bridges them.

I found the answer to that problem – some of the plugins aren’t renoise compatible, but most of them it was that they require being in very specific file directories. I cant just lump them into one VST folder, for many they have to be in exactly the path they default to or they wont show.

the other issues im not so sure about. its like Renoise goes crazy when i hit escape for record mode. I can listen and play with synths and effects outside of recording, but as soon as I press escape its like there’s a monkey banging on my keyboard.

esc= record …every note you play will be entered in the patten editor without a note off …unless screen is set to scroll …
The space/lines between notes depends on the edit step .
caps lock = note off .
Try these things with just a sampled instrument instead of a vst , so you can determine the problem .

Put the VST’s in C:/Program Files/Steinberg/VstPlugins (maybe ‘Program Files (x86)’ on 64bit systems, i’m not shure)
This seems to be the default folder for many vst’s.

I got most of the vsts to show up (at least the ones I really want) by putting them in their favorite directories instead of all together.

The other issue still happens, I cant stop the screen from scrolling…pressing space makes it scroll super fast, pressing it again slows it down but in Reccord mode after pressing escape the screen Always scrolls and always shows “note off” after every input. Like someone is holding down backspace. but when I type in other programs it doesnt constantly erase my text.
I am using an external usb keyboard on a laptop because some of the keys on the inbuilt board are shorted out. I think renoise may be detecting some sort of input conflict?
in a couple weeks ill get a midi-usb controller and pick up a new pc keyboard and see if that helps, for now the program is pretty much unuseable. I was just hoping there was some setting I may have accidently changed that automatically "note off"s in record mode, but it doesnt seem likely since the same issue recurred after uninstalling and reinstalling the program.

I feel like an idiot. Problem solved.
The broken inbuilt keyboard was conflicting with the usb keyboard, and for some reason Renoise is the only program that received odd effects from it.
But Renoise was literally receiving constant “backspace” and “down arrow” input from the internal board, plus whatever I was pushing on the exernal.
Completely removing the internal board solved almost all problems, and swapping in a different usb keyboard solved the rest. the cheapass one I had was weird about sustaining keypresses unless more than one key at a time was depressed,
it works like a champ now and I can get back to learning the actual program instead of fighting my computer.
Thanks for at least pointing me to it not being a settings problem and it being my pc/peripherals. Hard to know where to begin when I dont have anyone to ask IRL.’
edit: btw the input errors were detected by deliberately using a “keylogger” virus, which was detecting inputs I wasnt pressing. yay virii.
now my kingdom for a snow or ti.