Cant Turn Chord Mode Off For Midi Devices?

When I disable chord mode in the pattern editor, this affects input from the computer keyboard, but not from Midi devices or OSC. These continue to behave as if chord mode were enabled. I don’t get this behavior in 2.6. Does anyone else get this?

Hey nism,

Works just fine here, but the SHIFT key will also enforce chords in step recording with MIDI, just like the computer keyboard does.
Would be great if you could give us a few more details. How exactly you are recording in Renoise (EditMode, PatternFollow) and what exactly is the output.

Hi taktik,

Here’s a short script that I used to test the OSC behavior. It sends 4 note on events and no note off events.

If I set edit step to 1 (and the song is not playing), then in 2.6 it generates 4 notes on different lines in the same column, which is what I would expect. In 2.7, however, it generates 4 notes on the same line in different columns. I would expect such behavior only when chord mode is enabled.

There is something strange going on with midi, not all devices are affected. I did my first test with an Akai MPD24, which displays the behavior I described in the first post. But I just tried an EMU Xboard, and that works fine. Then I tried the MPD again, and it still has this problem. I checked if it sends note off events, and it does. Renoise registers these events too.

It doesn’t matter if I use Follow Pattern and play the notes live, or if I have Follow Pattern disabled and use the cursor keys or edit step. The results are always exactly the same as when chord mode is enabled. I also checked the shift keys, restarted my computer, disabled all tools and nothing made any difference.

Here’s a screenshot, though there’s not much to see. I made this pattern by twice hitting two pads on the MPD at once, the first time while the song was not playing, the second time while it was. In 2.6, everything would be recorded to the same column and one of the notes on line 6 would be missing.

I hope this helps.

IC. We do this, in order to record multiple mapped instrument for a device correctly:
If you assign “MIDI Device A” to instrument 1 AND 2 (to play them coupled), this must be recorded as [c-4 01 | c-4 02] in one track, with or without chord mode enabled.

So this basically happens every time we do receive multiple events for the same note in one track. Its up the the OSC script to send Note offs correctly as well then or not. That the Akai MPD2 sends out two note on events per click is kinda strange, and maybe something that can be turned off? For playing back instruments this definitely does not make sense.

OK, that makes sense. I have the MPD set up so that the pads send the same note on different channels, so that was the problem. It works fine if it sends different notes.

It’s just a pity that I can’t use some tools that I wrote for 2.6 anymore (and I don’t see a solution either), but it’s no big deal. And anyway, there’s more than enough good stuff in 2.7 to make up for that.