Caps Lock Fail

Built a new ATX, upgraded to win7 64bit (DirectX11). Everything is great except now caps lock only sends a note-off if you hit it twice… (toggle switch)

This issue has been posted a few times. I know its not anything new and its not exactly renoise’s fault, but it seems the bug is spreading… (not literally).

My workaround was to reassign the note-off key to “`”. Gonna take some getting used to but the other alternative, that key-mapping app hack, is too convoluted.

Hope this gets resolved some day. :walkman:

Perhaps you should look in the keyboard configuration of your windows system properties.
I think this might be related to a possible feature which anticipates on the fact one might unawarely hit the caps-lock unintended.
(password fields).
So there might be a toggle where you can reset this by simply unchecking a checkbox in there.

If you have to hit capslock twice, this simply means either the windows environment no longer sends the first hit-signal to the applications or a different keycode is send to the applications. (The second situation has to be fixed from within Renoise, the first possibility cannot be fixed from within Renoise)

Totally understand. I made the post so it would go down on record in the forum. When I first looked I only found 2 posts about it, so now maybe a third will show up. They reassured me so I didn’t freak out and waste too much time trouble shooting it.
On that; I’ve looked in the obvious places but didn’t find any specific settings. I’m using a generic ps/2 qwerty with the os driver. Any suggestions?

I’m having the same issue, also using win7 64bit. I’ve used autohotkey to monitor keyboard input, and it seems that pressing the Caps Lock button twice generates the exact same input: scan code 03A and virtual key 14, which google tells me are indeed the correct values for Caps Lock. So it seems that at least autohotkey sees both key presses as identical. I’m not sure what this means, but I thought maybe this information would help to narrow it down.

This is getting weird. I just noticed that in the Keys page of the Preferences window, when I click on the ‘new assignment’ area, Caps Lock always gets recognized, regardless of the current Caps Lock state.

So it seems that Renoise can register both events and recognize them as the Caps Lock key being pressed. It ignores ‘Caps Lock off’ in the pattern editor, but not in the key assignment window.


Good find!

Another thing is Renoise uses DirectInput (from directX). I already forgot that, (Else if it didn’t, you could use Bome’s MIDI translator for instance, which you can’t because of DirectInput being used)
I have no idea if there are configurable items in the directinput tab of the DxDiag program (you can start dxdiag in the “run” field). Most likely not.

I had this issue on my Acer 5920G notebook with Windows Vista. I only use Linux on it now, but before I solved the problem using a software which changes the key input, so that CAPS LOCK resulted in another key, and assigned that key to “Smart note off” shortcut

Thanks for the replies. I guess the DirectX thing makes this more complicated than I initially thought. Anyway, I am so used to pressing caps lock twice that I hardly notice anymore. At least this way the caps lock indicator stays off, so I’ll think of it as an energy saving feature. ;)

got the same biyaotch on my vaio laptop

Same problem for me. Win7 x64. I’ve worked around it by changing the keyboard shortcut to “A” for note-off. A bit weird, but it’ll have to do for now.

But god it needs fixing. (Not fixed as of R2.6 Beta 2)

ow, and I thought I was going crazy.
Same desktop here but upgraded it from XP to Win7 (not in signature yet)

… for me it was the keyboard (one of those microsoft keyboards with a boxed “A” on capslock).
as soon as i switched it to my old self- painted ps2- keyboard from hama the capslock worked correct again.
my guess (after a few search- attempts), its a “feature” where the specific ascii code is triggering a routine in the new OS, dont know.
maybe someone knows whats going on.

That’s very weird, I use the same keyboard. the only difference is the OS.
XP works ok Win7 I get the dubble click

Re: Bug, needs a fix:

Actually I have the very same problem here on my notebook. And I looked at this more than once without being able to find a solution. When the caps lock is stuck, needs to be pressed twice to do its job, it behaves exactly like this everywhere in direct X and also in the windows APIs: Aka, there is no way (I found no way) to query its “real” state in order to hackaround the problem. Looks like device driver devs want to workaround other probs with this: querying the caps lock state (is caps lock enabled or not), is easier this way. Because no one else uses caps lock like a normal key, I don’t think we can expect a fix from microsoft for this.

So the only thing we could do here, is avoid using caps-lock at all for anything but entering text. Using some other key as default for note-off.

Or add two shortcuts for Note-Off. One should be CapsLock, the other “something else” by default. So people who have the caps-lock problem can use the alternate shortcut. Will also have to rewrite, update all your docs.

The “A” key might be a good candidate for a new default key binding?

What about this one?

There didn’t seem to be any conflicts on my system at least.

I think it might make a bit more sense than using “A”?

Today marks the day that Fast Tracker officially died…

Sorry to drag this up again, but what’s the likely decision about this for W7/64 users? Although I guess I can always reassign, it’s a bit of a pain in the arse - no thanks to the inconsistency of this OS! ‘Accent’ is used for metronome, so I guess ‘A’ would be the likely candidate imo.

Òk I tried to win this double tapping but it’s just too annoying
I say ‘A’ as new default.