Clone pattern stopped working - The operation would create more then 1000 patterns


When I clone a pattern I get a message box that tells me:


I don’t want thousand patterns, one would be enough :slight_smile:

Can somebody tell me how to fix this? I can’t clone a pattern anymore.

I fixed it by deleting all patterns.

Did at anytime during the song creation you surpass the 1000 pattern limit?

You got to be careful here because you can get Renoise (3.3.2) file into this situation after messing around with 1000 patterns:

1000pattern.xrns (25.4 KB)

Load the xrns in and try to add or clone a pattern.

Possible “fix” here is to select Edit menu item ‘Delete unused patterns’(?)

1 Like

I had only 6 patterns of 256, then I tried to split te pattern into 2 x 128, but didn’t know how I had to do that. Then the error came up and after that, when cloning a pattern the error keep coming back.

I copied a pattern to my clipboard and deleted all patterns and pasted back the patterndata to the empty pattern, that worked.