Close Laptop = Audio Device Fails To Open

Hi there,

If Renoise is open and I close my laptop (Dell Latitude, Win 7 64bit) and open it again I get the message: Failed to initialize audio device blabla, audio is disabled.

If I go in preferences the standard audio device is still selected but everything I select gives the same message. I have to restart Renoise for it to work again.

there is a “reinitialize” button under the device chooser, did you try pressing it? if yes, I think Renoise can do little about your problem

Yes, even then I get the same message.

Go to: Control Panel > Power Options > Advanced

What setting do you have selected for ‘When I close the lid of my portable computer’ ?

If you have it set to ‘Stand by’ then try changing it to ‘Do nothing’ instead.

This is what I always do. I hate hibernate/sleep mode! If you like it then it may be a pain though. (Closest option may be something more like Turn Off Display.)

Hate the Sleep Fn Button too!! (Or sleep mode buttons on keyboards in general.) Always disable or remove them personally…

is this something occurring with 2.7 only? otherwise I think it shoud be moved to general help/bugs forum

I think this a simple help and support question. Nothing any audio program can do something about it.

Except some may turn off external monitor you have connected and have no way to avoid it unless there is a true Do Nothing option. In fact I’ve found sometimes Do Nothing will turn off the external monitor on closing, sometimes wouldn’t, in the past.

But my point was more it may not be named as such.

wow, thanks for asking this question td6d. i ran into this a while ago and decided to ignore it (don’t close the lid), but now i’ll check out the power management to disable sleep mode.

Also BIOS setting: Disable S3 Sleep mode. This is the only way I found to stop the Sleep button (Fn+F4, between Mute and Vol Down, on my laptop) from really annoying me!

Think I’ve remembered that right anyway…

well, since i did a clean install of various OS’es, my laptop’s Fn-keys stopped working altogether. don’t really miss them, have AutoHotKey for stuff like Mute/Volume, and i have a laptop with a numpad so don’t need that through Fn either. good riddance!

Vol Up/Down and turning on an externally connected screen are the only ones I ever use. Oh yeah, and FANS TO FULL SPEED CAPTAIN occasionally. Oh, and Wireless On/Off. EDIT: Oh, and Scroll Lock. Although I have a NumPad the Scroll Lock is access via Fn combination and a still a nicer way to togle Pattern Follow mode in Renoise.

OK I do use them, I’m just lying to myself.

(PS where’s you’re entry? :P )

yeah okay i have a wifi toggle and also a fantastic ‘eco’ toggle (it will reduce brightness!), and these still work (because they are hardware buttons i suppose… don’t really know, they keep working in Linux as well)
as i said, for the Vol Up/Down/Mute i use a AutoHotKey script.

(PS - i’ll reply in the DDRC Round 11 thread, so as not to hijack this one to death :) )

All my Fn+Key combinations work in Linux as well and Windows.

Sorry td6d. Did the replies about Power Saving and Sleep Mode help? Or did you know about these already and it’s a different problem? Does it happen with everything that uses the (ASIO?) driver or only Renoise?

This solution may seem less than sane, but this is how I fixed a problem with a similar lid closing issue where windows would see the display as completely unplugged rather than just shut off:

After I guessed this is an “ACPI lid” problem, I searched forums and finally found this solution (forgot the forum link, sorry):
The solution is to go to device manager, click on System Devices and ACPI lid. You would notice that you cannot ‘disable’ it. Don’t uninstall it either - it causes problems with the OS. Instead, update the driver, say you will locate it yourself, uncheck compatible devices and update it with the “Volume Manager” driver. That’s all - reboot