Consistent Rendering

Depending on the song and the VST effects/instruments used, I have to navigate to the first pattern, press play, then press panic, then render to get consistent results… and it’s slowly getting on my nerves. I really think that when you render a song (or use “render selection to sample”), it should always be the same, no difference between hitting render while the the song is currently playing or hitting render after having pressed panic several times. I wouldn’t even care if it “broke” the behaviour of all my songs if it just was consistent from then on! Undefined and random (unless you want random) = not good.

It sometimes seems that you have to press panic twice to really get the CPU usage down? Also, when finished rendering Renoise will make short a noise at the end. I guess it could “internally press the panic button” (which would need to be fixed so that pressing panic more than once offers no additional benefit) before starting to render, and after having finished and before “giving the soundcard back” (if you know what I mean, to avoid the sound “trail” from rendering).

(whoops, I actually meant to post this in suggestions sorry… but then again it kinda is a bug?)

That’s what we already do and this caused a lot of troubles with sticking first notes. Those probs could be sorted out at the end - well, I hope for most VSTs.

The only thing that would always work is a recording alike rendering option, which would record in realtime while playing, aka just write out the outputs while playing.

Have you already tried out the pseudo realtime option in the render dialog?

The thing is I can get consistency by going to the first pattern, pressing play (dunno if that is necessary, it’s habit carried over from older versions where it was), pressing panic, and then rendering (or rendering right after loading the song without playing it), so maybe Renoise could do more to get into a “defined state”? If it can be done manually, it should be possible automatically, once you figured out what’s going on?

I just did, it doesn’t make a difference: it still sounds differently when I hit render while playing, as opposed to the procedure mentioned above.

(sorry for the slightly annoyed undertones in the first post… it’s not the fault of Renoise that I am “working” on dozens of songs in parallel…)

Some sort of optional song reloading might work. Before rendering i just save the track, reload it again from disk and do the rendering then. Works fine for me.

But that’s worse than navigating to the first pattern and pressing panic…

Then you should give us some more details about which VSTs you are using and what exactly you mean with “initial” state.
All the Renoise internal sounds from samples and the internal effects will sound exactly the same (except you are using random LFOs). if not, thats a bug.
With VSTs this is of course totally different. VSTs which run random or unsynced (not time synced to the Renoise song time) LFOs or other event triggers will never sound the same. Whatever you do.

Oops yeah. I’ll try to isolate it, to be honest I haven’t kept track of it. But it wasn’t random, that is it is definately song/VST-dependant. If it boils down to just one effect or something like that I’d like to apologize in advance <_<

Well, whatever it is you get after loading a song (except with those VST’s which begin making noise right away (I’ll try to find the example for that, I’m pretty sure I have one song that still does that), with those it’s probably loading the song and pressing panic once ) or, when you “have done stuff” after loading, going back to the first pattern and pressing panic. I don’t know what exactly is the difference between that and hitting render in other situations, I was kinda assuming this is more or less known about already :confused:

I know and that’s not what I mean.

Yes, I know that too. But again, what I’m talking about is the song sounding the same always when you render right after loading (or bend over backwards to “reset” Renoise), but different/random when hitting render while you’re somewhere in the middle of the song. That’s why I said “undefined”… if Renoise is a clock, something is rattling when you hold it next to your ear and shake it (and I’m not dissing Renoise, it’s actually a compliment to so distinctively notice that something is “loose”, because everything else is so perfect :D)

In my case your method hasn’t helped (Filterbank2 endless echos), even when panic was pressed multiple times. With optimized reloading i’ve thought more of just destroying the VST plugs and rebuild them, wouldn’t take as long as complete reloading. But it’s really no big deal for me.

Okay, try this (required VST -> http://www.numerisson.com/novaflash/xmax.htm ). Rendering right after loading, it always sounds like this, but when you render several times after another without reloading (or going to the first pattern, pressing play, pressing panic…), it freaks more and more, like this.

If it wasn’t for me I wouldn’t make a thread about it I guess… so what about an option to, say, re- instantiate all VST’s before rendering?

(and regarding my example - the rendered version is different from the xrns only in that it also has buzmaxi for more loudness on the track, and I tried it disabled LFO’s too, it doesn’t seem that.

By the way: even random LFO’s can be reproducable by using the same seed value (-> user controllable seed would rock!)…

it seems to me that you are using some weird vst plugins… i have never had such problem.

Now that was helpful.