Controlling roland midi synth module with Renoise

I have an oldRoland XV-2020 module, which are capableof playing back 16 different sounds at the same time. It’s a (multitimbral synth).

Im trying to control it with the renoise SW.

My problem is that it seems likei only canuse the same sound for all tracks in my sequence. When I change channel, bank and program

under output device, the sounds are changing and i can record what i am playing. But ifI go to a new track and

select another sound and record again, then the sound does also change for the previous track.

Does anybody know how to solve this ?

Thanks , that was exactly what i needed. I have now recordeddifferent instrumentsfor 2 differenttracks.

I will try to play around with it a Little bit more tomorrow.

I have now tried to use my Roland synth module for a while, but it seems like bank select does not Work very well for Roland, maybe I am doing something wrong.

But I can see that other users have had troubles with this also. They mention that it has something to do with in witch order MSB and LSB are send. I think Roland

expects MSB to be send first.

As it is right now it is only workingwell i set Bank select to off in renoise and then i can only select between user 128 patcesfrom my synth.

It could be very nice if it was possible to choose between all sounds and drums that are available directly from Renoise. But maybe it is possible somehow ?

Hey, yes it is possible to select banks as well, with a workaround:

  • inspect the manual for the xv-2020 and search for NRPN, MSB or LSB, and hopefully you will find something explaining how an NRPN message for this task should be set up.
  • then make a doofer that forms this NRPN message using a “series” of CC messages

I did this for my JV-1080, so you can download the bank doofer here and inspect how it is set up:

if you’re lucky it might even work for your 2020, if the implementation is the same :slight_smile:

Hi, it sound good if this workaround will Work :-). I have downloaded the 4 files. But how do I implement and useit in Renoise.

Its a new area for me, so it would be very nice if you could explain this.

Hi, sure I’ll try to explain:

  • first, load one or all the doofers into your Track/DSP chain in Renoise (via drag and drop, for example)
  • click the “show more” cursor at the right side of each doofer so you can see all the settings inside
  • make sure that the instrument number inside the doofer is the same as the instrument number where you have your MIDI instrument set up for the 2020.
  • now try to tweak some Bank/patch knobs in the doofer and see if your module responds
  • if not, you need to change the “rules” inside the doofers so it matches the MSB/LSB/NRPN commands in the manual for the 2020.
  • if you get everything to work, just save the edited doofer and you won’t need to do the same changes next time

Tip: if you are using a custom Renoise Song startup template, resave it with both the MIDI Instrument and doofer set up correctly, so it’s all ready to go on your next project.
I have done this for 8 hardware synths, each with their own track + chain of doofers + their own midi instrument/port. Saves a LOT of time whenever I start a new project.

H Again.

I think i managed to load the doofers. I can change things like cutoff and resonance and other filtersfrom the Renoise software and its very cool , so i think my XV-2020 module must be compatible with

the JV-1080. But i cantsee where I can select the bank andpatch i want to play. It seems to me that a doofer is a tool forediting the sounds. So can you pleasehelp meonce more ? It would be very muchappreciated. You have been a great help so far.

Please forget my previous message I cant control the XV-2020 anyway. The doofer was working but it was with one of my samples in the sequence.

I have now placedthe JV-1080 .xrdp files in this folder, (C:\Program Files\Renoise 3.01\Resources\Library\Effect Presets\Doofer).

I could see thatthis foldercontained files with the .xrdp extension, so i guees this is the right place to storethem ?

But how willthey become active ? Maybe i have to modify the files somehow anyway. In that case do you or somebodyhave a description/tutorial about how this

can be done ? The files seems to contain a lot of data, so it will be difficult for me to modify them in the right way, without some basicinformation.

After i placed the files in C:\Program Files\Renoise 3.01\Resources\Library\Effect\Preset\Dooferi cansee that i can select them in renoise as doofers now and load them into renoise. But i have not been successfull selectingbank andinstrument from my synthwith it yet. But i will try tosee wheter i can figure it out.

I had to modify the.xdrp, (doofer)files, because the Bank Select numbers is different for the RolandXV-2020, so it is working now.

Thank you for all the support.

hey, sorry for the late reply, glad you figured it out!
yeah that’s what I meant, the numbers/codes have to be changed if the 2020 has a different implementation :slight_smile:
you just edited them directly in renoise, right? shouldn’t be necessary to open them up in an editor or anything like that)

anyway, hopefully future renoise version will support more customized doofer options, so we can use switches instead of circular dials for stuff like this :slight_smile:

I did the editing in a text editor. I was not aware that it could be done directly from Renoise, so maybe that would have been easier, but im

used to XML files and stuff like that, so it was not to difficult, to see what i had to change inside the file.

Ido also hope thatRenoise in the futurewill support switches for doofersin the future. But it would also be nice if it was possible to select the right banks for

Roland synths without using doofers. Ifit was possiblejust to type in the MSB and LSBbank number and select the order in the Midi part of the SW,then it would havemuch easier

from my point of view, (But maybe its only a problem for Roland synths). I would never have figured this out without your help. :slight_smile:

agree. but hey now i remember, in some other thread a while back, I think it was taktik or one of the other developers that suggested to improve the bank select function in Renoise (more options for how to select bank / mode), to avoid this issue. so hopefully it will be in an update soon!

Lets hope there will be an update later that improves this,but apart from that i think Renoise is the best and most intuitivesequencer i have ever used, and now where i have this

workaround. I can live with it. Thanks Again.