Controlling Send effects with a controller

Probably just doing something wrong here.
If I add an instrument automation device I can control the cutoff etc on a synth that is in the instrument properties box and then assigning that to a midi control on my midifighter.
How do I do the same with an effect that is in the send channel?
I have Valhalla freq echo on a send channel but I can’t seem to be able to find a way to assign any of its controls to my midi device.
Any help would be appreciated.

Did you try command + M? This opens the midi mapping dialogue, where you should be able to assign any parameter to any midi device

That works ok on any instrument that’s in the instrument properties box, it’s the send fx that don’t show up there.
I added another effect vst (Audio Damage Dr Device) on another send channel and went into instruments and added it as an alias and that does appear in the instrument properties box.
Is it only certain vsts that allow them to be used as an alias?

Seems like if you add a VST effect (caveat ive never done so) to a Send channel,
the paramaters appear automatically in the tracks device chain, every time; after
that is click Midi Learn and map it.

Is the track device chain area thing hidden?

That is true of vsts added to a track channel. Send effects work differently.
On a normal track you add a vst such as a synth or delay etc and then add an Instr Automation to gain access to the parameters of that plugin.
When a vst is placed on a send channel adding the Instr Automation doohickey does nothing because it wants to choose from the instrument properties panel which is why you have to create an alias for it.
I think what has happened is I’ve been doing it right all along but choosing vsts that won’t allow an alias of them to be created.
Valhallas free vsts, the Freq echo, Space modulator and Supermassive won’t map.
After trying lots of different effects I found that 80% will allow an alias to be created but some just won’t.
I was maybe unlucky in choosing vsts that wouldn’t alias and assuming I was doing something wrong when in actual fact I am doing things right. It’s the vst that is the problem.
So on that note I will declare this as problem solved.


Dave that is a send track pictured above, notice the cursor.
Are you using latest version of Renoise?
Are you using VST3? Try VST2?

Ok, got supermassive and had a go at it.
This VST did not automap; so i reached for a tool called ‘MUC’.
MUC was able to expose the parameters for MIDI Map.

Perhaps some methods used here for this tool could enhance Renoise’s handling in this case.
The tool ‘MUC’ is available for use here on the forum; located here:

I’m on 3.4.3 which is up to date.
I see in your picture that it is a group that you have put your effect onto.
I am using the send tracks positioned after the Master in the layout.
Technically both should be the same result as far as mapping goes.
Now knowing that your version of Supermassive appears exactly the same as mine, i.e. without any parameters visible further consolidates the view that it is the plugin that doesn’t want to play nice.
I’ll take a look at MUC when I’ve time to sit and study it. Looks like more than a five minute read.
Thanks again.