Cpu Problem With The "sugar Bytes" Effectrix Vst

I saw awesome video’s of this tool and I would like too buy it.
(sorry dblue I got to have this for mac :P)

But if I put it into renoise the cpu climbs in 5 seconds to 100% and it stops.

Any suggestions how to avoid this?

My computer:
Macbook 2.16 GHz Intel Core 2 Duo
osx 10.4.11

I cannot imagin that my computer is the problem :S
Be gentle… I’m a noob considering cpu, latency, memory etc…

On Windows, some plugins are not capable running on a multi-cpu environment.
For that reason a switch has been added to the vst-cachelist to disable multi-cpu for specific plugins.
New plugins are by default multi-cpu enabled.
I don’t specifically know if the trigger is also being applied on Mac environments as i know that Renoise was at least not capable of shutting down one of both cores. (This does not necessarily mean that it won’t be able to tie the VST just only to the first processor.)
The quickest thing you can try is to manually disable multi-core for Renoise completely and see if that gives any improvements to the plugin itself before it is worth it to mangle with the cache list.

Just tested this and it works just fine here. Does it always overload or only when you do something special?

Yes, but multi-cpu specific problems only occur when running several instances of the same plug. charly tried only one instance?
Also those problems should be rare these days with new plugs. Nearly every developer has multi core CPUs, many hosts support multi CPU processing these days…



try turning off airport and see if you get a performance boost.

I suppose the demo version also?

I just press play and the cpu starts to build up, and if I press play and stop, my cpu keeps climbing after the stop to 100%

and it’s the only vst I run :S

My wifi disabled too, but I don’t think that would be the problem because it never has been.

More ideas or should I just not buy it :P ??

There’s another OS X GLITCH clone out there which is cheaper:


EDIT: I just tried this and I don’t understand how it works, or it isn’t working… Anyone have better luck?

EDIT2: Restarted Renoise, now it works?! Never mind.

thank you I’m gonna try it this evening!