CPU usage problems - I can only use 50% of my cpu's

Hi,

When I load a song, the cpu usage shown in Renosie is much higher then shown in W10 task manager. Not that I find this a problem, but when my cpu percentage in Renoise crosses like 50 or 55% everything starts to crackle, even with very large buffersizes on my (really new) ssl 2 audio interface. I’ve set a buffersize of 1048 by default for as long as I can remember. (This problem also existed on other audio interface btw, like audient and m-audio)

I’ve configured windows to run at best performance in all settings and only have legal software (I guess warez could be a source of strange problems.)

PC
intel i7 4790 cpu with 4 cores at 4gz
hyperthreading on
32GB memory
Renoise runs on SSD
Only a midi card to one usb 3.0 root hub and a audio interface to another usb 3.0 root hub.
I even have my mouse and keyboard on an old 1.1 pci usb card to not let them interfere with my audio.

When I turn hyperthreading off, it doesn’t run better or worse.

I hope someone can help me use a larger part of my cpu’s for Renoise.

ps: I wanted to add a screenshot of my cpu usage in taskmanager and Renoise, but I don’t know how to add an image. Anyway, taskmanager says 24% and Renoise 51%, futhermore 26% of my memory is in use by all programs.

1 Like

Try plugin you audio interface with no hub also try different asio drivers like asio4all or fl studio asio

Thanks for your reply.

asio4all is not a driver it’s a wrapper that uses your wdm drivers to create an aggregate device on windows, it doesn’t replace the asio driver, in fact it doesn’t use asio at all.

I’m not using an external hub. I have connected only one device per root hub on my motherboard. (a root hub on your motherboard has like 4 or 6 usb ports that all share the same hub, but I’m using only one device per root hub, and don’t use the other ports) So no other devices can interfere.

I have no extra programs running I have this whole pc only for running Renoise and plugins, In (my) theory it should be a really good environment to run Renoise on. BTW, I have these same problems in Ableton.

Maybe you use to many plugins that your hardware cant handle try bouncing some of them to audio

do this: https://help.ableton.com/hc/en-us/articles/115000211304-How-to-enable-the-High-performance-power-plan-Windows-
enabling the performance power plan with 100% for min/max CPU makes a whole lot of a difference on my 5820K.

also make sure that you have enabled all CPU cores:
image

and also ensure that the plugins of your project are allowed to be spread across the available cores:
image

also note that realtime audio won’t run in realtime until 100% CPU load. it will always crackle beforehand unless you use the hugest buffer there is.

towards the task-manager vs renoise CPU meter:

  • task manager won’t show 100% cpu load until all cores are evenly saturated at full load
  • renoise will show 100% (or close to 100) even if only one of your cores is at maximum load

so on a CPU like yours, which features 4 physical + 4 logical cores, a load of 12,5% in taskmanager can translate to 100% in renoise.
the more cores your CPU has, the more drastic the gap between the two percentages can get.
on an 8 core cpu with SMT enabled, a load of 6,25% in taskmanager can already translate to 100% in renoise, if for some reason multithreading can’t be utiliized.

Thanks Kieth, I’m gonna check it out right away.

I already had everything configured like you sugested. I don’t know if I should be happy with that though, because now I can’t try it out anymore. :slight_smile:

damn… well even though 55% cpu in renoise is really low for exposing crackles, i guess there are no other options to get around it than either increasing buffer size or upgrading your hardware.
at least i’m out of other ideas :frowning:

Thanks for your time. I gues this is not normal behaviour then I need to search a little further.

Just wondering, does it make any difference (be it better/worse/exactly the same) if you connect your audio interface to a usb 2.0 port?

My audio device is 2.0 but connected to a 3.0 port, I only have 3.0 ports. I can’t test that sorry.

Ok, no problem (I think most of us are in the same position.) Just curious on the outcome if it was possible/convenient :slight_smile:

Should be able to drag ‘n’ drop the png/jpeg/whatever image file into the editing/reply discourse forum box.

Thanks for clearing that up, I couldn’t find an attachment button only button to link a picture.

And now for the good news!

Like I said, I have a new audio interface and found a button called ‘safe mode’. I clicked it and now my cpu goes up beyond 65% (I haven’t tried further) but I am able to add more plugins then I need, yay! I could never do that with my old interfaces.

I don’t know exactly what safe mode does, I couldn’t find it on the internet, it doesn’t improve latency, but does resolve the crackle I don’t know how it does it, because I can set smaller buffers without crackles, but then again my latency goes up, so what does it do different then just setting the buffer larger?

Anyway, setting the buffer larger, didn’t help me first, I had a buffer of 1048 and now I can set it to 256 or 128 and no problems still.

Now I can even record a solo midi track on buffer 64. I like that option, beacuse like I said I don’t care about latency, but larger buffers make the midi less tight then a small buffer. So 64 is great for recording midi triggered synths.

I’m super happy, thanks guys for trying to help me!

1 Like

Jamming with low buffer is sweet :stuck_out_tongue:

1 Like

@spdk which vstis do you use?

Most CPU hungry are iZotope Trash2, Fabfilter Saturn, FabFilter Pro-L, D16 Toraverb and SSL Drumstrip.

I’m having the same issue, but while rendering. It stays stuck at 40% with a Ryzen 5 3600 at boost clock + 2x8gb 2600mhz RAM :confused:

Using Windows 10 + SSD. I’ve tried everything mentioned in this topic.

Do you have hyperthreading or an equivalent of that on your cpu? You could try turning it off, I remember my previous machine ran much faster after turning it off.

Hello…in the event that your application is intensely getting to your HDD/SSD and spending practically the entirety of the accessible RAM, at that point it doesn’t make a difference whether it’s just utilizing 1 center or all the centers in your CPU, on the grounds that 100% usage is as yet 100% use. Various centers let you do genuine performing multiple tasks on a PC, since each center can deal with a totally independent application/stream/measure.

Thanks for sharing Tobe and welcome to the forum.