Crackling/Popping noises while watcing video on YouTube or using DAW

Hello everyone, I have this problem from 3 months since I bought my new desktop. The probem is; I’m having cracking/crackling/popping sounds/noises while watching videos on web or listening music with Spotify or playingback audio in my DAW (Studio One 5).

The crackles are getting much heavier and frequent while there is mouse activity (like moving the cursor around GUI on Youtube or adjusting plugins in my DAW)

Here is my system specs:

  • M-Audio M-Track Plus (MKII)

  • AMD Ryzen 2600X

  • Gigabyte B450M-H Motherboard

  • MSI RX470

  • 16gb ram

  • 500gb M2 SSD

I also should note that I don’t have any problem when I’m using the same USB audio interface with my 6 years old laptop. (Both Windows 10)

The problem is dissapearing when the M audio drivers are not installed. But I can’t use Studio One without it, so I’m also stucked there.

I tried to use Asio4All and FL Studio Asio but the latency is not workable in recording situations.

Here is the things I’ve tried so far:

  • Incrased the buffer size to maximum

  • Made sure sample rate is same everywhere (24 bit, 44100 Hz)

  • System power management %100 cpu

  • USB power save disabled

  • PCIe set to GEN3 in BIOS

  • C-State disabled in BIOS

  • CPU underclocked

  • Changed the GPU (it was gtx770 and now it’s RX470 and no change in crackles)

This might sound ridiculous, but if it’s a USB interface try setting the number of buffers to 3 (versus 2 or 4). For some reason audio over USB seems to work smoother with 3 buffers (even short ones). I don’t know if it has to do with the protocol or what, but just setting the number of buffers to 3 from 2 can significantly increase performance and reduce CPU over USB.

It’s worth a shot.

The problem is your external sound card.

It needs a DI box to prevent static noise from its sound output.

Maybe you have a problematic usb port try another one also be sure you have your bios and chipset drivers correctly installed before installing the M audio drivers.I have and audiobox 96 from presonus and it is usb 2 so when i had it in a usb 3 port it gave me problems check what usb ports the M audio is for