Crash loading Formula Device presets from file


(triple zero) #1

Description: Dragging a Formula Device presets file onto Renoise, crashes it.

Steps to reproduce:

  1. Download the file org.OopsIFly.ktrk1.xrnl from Zer0 Fly’s Ktrk Formula Device Presets thread

  2. Launch Renoise (I run Linux 64 bit v3.1.0 build 9 jan 2016)

  3. Optionally, click “New Song (no Template)” from the File menu, just to get it to a clear defined state, but it worked with several songs that I tried

  4. Drag’n’drop the file org.OopsIFly.ktrk1.xrnl onto Renoise

Expected result:

Renoise loads the presets and doesn’t crash.

Actual result:

Renoise hangs and I have to force kill the application (the top right X-button doesn’t work). Sometimes it displays the “saving crash backup …” line in the bottom status line, but sometimes it also hangs before that. Regardless of what it displays, I didn’t get a crash backup on restarting Renoise.

INTERESTINGLY, however, it does end up having loaded the Formula Device presets into the library!

This is weird because then, what is doing the crashing? But you won’t hear me complain too much because at least I can use those formula presets now :slight_smile: And I only lost a small amount of work on a toy project anyway (save often, yay)

To be fair I kind of wonder if this might been caused by some quirk of my own system or perhaps other tools I have installed, instead of a bug in Renoise itself. Because, seeing the amount of downloads for that file, I can’t imagine that I’m the first to report this bug? Or maybe everybody was like “ohnoz a crash, let’s restart Renoise, hey the presets are there at least, oh well, let’s make music now”.

Hopefully this bug report is useful to the developers. Let me know if you need any more info.


#2

I think you’ll find it has little to do with the formula device (or the OopslFly.xrnl file in general) triple zero . I think just loading/dragging dropping a blank library xrnl in Renoise 3.1/3.1.1 with Linux will crash/freeze. From the log file a possible backtrace (Renoise 64-bit 3.1.1 Linux):

Renoise LOG> Content Libraries: Found library 'org.4tey.lincrash'
***longjmp causes uninitialized stack frame*** : ./renoise terminated
======= Backtrace: =========
/lib/x86_64-linux-gnu/libc.so.6(+0x70bfb)[0x7ffff6597bfb]
/lib/x86_64-linux-gnu/libc.so.6(__fortify_fail+0x37)[0x7ffff66201f7]
/lib/x86_64-linux-gnu/libc.so.6(+0xf912d)[0x7ffff662012d]
/lib/x86_64-linux-gnu/libc.so.6(__longjmp_chk+0x2b)[0x7ffff662008b]
./renoise[0xebfa50]
./renoise[0xc0bb7a]
/lib/x86_64-linux-gnu/libpthread.so.0(+0x110c0)[0x7ffff75800c0]
./renoise[0xc5256e]
./renoise[0xc033d3]
./renoise[0x7a5662]
./renoise[0x43746c]
./renoise[0xeb905d]
./renoise[0xee39ac]
./renoise[0xc0a54f]
./renoise[0xc11db5]
./renoise[0xc32b81]
./renoise[0xc10b0b]
./renoise[0x43bade]
./renoise[0x43bec5]
/lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf1)[0x7ffff65472e1]
./renoise[0x431d0d]

(ffx) #3

Does not crash here, Renoise 3.1 .1 macos.


(danoise) #4

Quickly tried on Renoise 3.1, Win 8.1, no crash.

Haven’t tried with a blank/empty library file, but it sounds like it could be a linux-specific issue.


(kytdkut) #5

Tried loading that library on linux, did not crash either. I’m using 3.1.1.


(Zer0 Fly) #6

I do not remember any problems when I made and tested the library. Xubuntu 16.04 with random upgrades.

I do however get frequent random crashes with no apparent reasons while working on linux, often related with libc/libpthread. The more complex the project, the more often it might crash (at totally random times). But those most probably have nothing to do with this bug.