"create_sample_data()" turns over-sampling on?

It looks like doing the “sample_buffer:create_sample_data()” function always default the looping and interpolation settings of the current sample. For the tool I’m working on I use automation like:

renoise.song().selected_sample.interpolation_mode = renoise.Sample.INTERPOLATE_SINC
  renoise.song().selected_sample.loop_mode = renoise.Sample.LOOP_MODE_OFF

… to workaround the behaviour, but there isn’t such function for the over-sampling switch.

Since it’s newly introduced stuff in 3.1 I guess the API (or the document) hasn’t been updated for this?

Hello. Indeed should not be enabled by default when creating a new sample buffer from Lua (will fix that), but you can change the oversampling from Lua via:

renoise.song().instruments[].samples[].oversample_enabled, _observable
 -> [boolean]