Create Xrnx Zip.Lua

Zip: deleted contents, exit code 1
cd “C:\Users\vvoois\AppData\Roaming\Renoise\V2.7.0\Scripts\Tools__MyTools__\com.renoise.testtool.xrnx” && “C:\Users\vvoois\AppData\Roaming\Renoise\V2.7.0\Scripts\Tools\com.renoise.CreateTool.xrnx\zip.exe” -r “C:\Users\vvoois\AppData\Roaming\Renoise\V2.7.0\Scripts\Tools__MyTools__\XRNX\com.renoise.testtool.xrnx” *
Zip: Unknown exit code encountered: 1

I tried to find whatever code 1 means. The best they can come up with is
/* 1 */ { “”, “”, ZE_S_UNUSED },

still code 1 seems to be used. Why do they use it if they don’t describe it?

I had this kind of case as well when i was messing with the infozip library in the past.

It seems that code 1 is used when the program does everything without receiving system errors but doesn’t find an output file as result.
Or it retreives a system error that it doesn’t have a mechanism for.
I’m running it on 64-bit windows called from within in a 32-bit application…

Infozip error codes:

0 and 1 are both OK. It’s how we did it in XRNS-PHP.

EDIT: On second look I see that 1 is undefined for ZIP, instead of UNZIP, which is what you guys are talking about. My mistake.

Not in particular, is it voiding “” toolnames through this way perhaps? (copied the tool to the MyTools folder)
I also made one change to the API versioning inside the creattool mechanism (Because the tool was still attempting to save tools as API 1.0) but i changed that back to see if it made a difference, unfortunately not.

In my case it tried to access the Documents and Settings folder… which no longer exists on Windows 7 64 bit, but the tool had it saved in its preferences file :D